Brave browser doesn't open in PC [WIN 11]

Whenever I open the shortcut on desktop, a popup appears, which says; ‘The File or directory is corrupted and unreadable’

When I tried to open it through Program Files/Brave Software/Brave-Browser/Application/Brave.exe It says that the windows can’t find the file.

When I tried to get some info from Settings/Apps/Apps Features, even though there is Brave Browser, it has no icon and does not show the storage space used.

Also the Task Manager, only BraveBrowser Software update can be seen once and BraveBrowser Software update (32 bit) twice.

I have been using brave browser in this PC since Jan 1st of the year, after formatting and installing WIN 11 onto this. I have been using Brave since 2020, and didn’t have any this kind of experience before.

Attaching the errors shown while I am trying to open…


Please reply as soon as possible. I have a lot of important Bookmarks and Documents saved in it !! :grimacing:

@IndianAsian are you able to use a different web browser to go to https://brave.com/download/ and download/install Brave again? To be clear, I am not instructing you to uninstall Brave, so please don’t do that. The purpose is doing this manual download is that it might fix anything that is corrupted/damaged, if that’s the issue. In other words, it will do a manual update/repair.

It would be nice to know if this would resolve it?