Brave Browser does not Mine javascript on non-active tabs


#1

I know you want to avoid drive by miners, but I develop a browser miner for WordPress for rewards sites that users activity log in and consent to and I noticed that if the tab is not active that it does not mine.

Perhaps a settings for the users who want to earn points and rewards for doing crypto mining via browser could right click and enable to be active as I do not want to keep that tab always on the forfront while doing development while testing so I know users do not want to as well.

Again, I do understand the need to keep silent miners out of the picture but browser miner for virtual rewards with consent should not be punished. Thanks!

Felty (vidyen.com)

[edit]

I confirmed that Chrome does not have this same behavior, and if you have dual monitors, you can just put an active tab on another screen to bypass, but my users may not be as fiat rich as I am.


#2

Hi, apologies, but we’re not going to permit mining in inactive tabs within Brave.

We had a big back and forth with Salon.com when they tested this a while back (with consent) as well.

This may change in the future, but is the case for now.


#3

Well its disappointing, but not the end of the world as I can just put in the documentation to recommend Chrome as default software to mine for the sites that use the plugin. (You know I don’t even test Edge)

That said, I still test with it to make sure it compatible with active tabs.

Perhaps (if browsing mining takes off as I hope) you could have an option to white list sites. Otherwise, for long term miners, they are used to installing custom software anyways.

Thanks for the response! (I still love the Brave browser regardless)