Brave Browser Does Not Display Some Sites

I have a sudden problem this last week with the Brave browser on Linux Ubuntu.

I run Linux Ubuntu 20.10 LTS on three machines, but only have this problem on one machine. Before it worked fine. The machines are all on the same LAN.

Brave does not display some sites, or only partially. In particular I have this problem with Yahoo Mail. But it is not just Yahoo, other sites as well.

It does not log me in - name and password prompt from Yahoo occurs, but after password nothing happens. Eventually a page appears from “” saying “this page isnt working, didnt send any data. ERR_EMPTY_RESPONSE”

I dont have the problem with Google Mail.

I also have problems at times logging into Lastpass Extension on Brave on this machine. But then eventually Lastpass works (after trying again and again at different times). Again, it was all ok until about a week ago.

But the website problem still remains even when I get into Lastpass. And it isnt just Yahoo, I have the problem with other sites where a password or login is required.

I also could not even login to Brave on Brave on that machine. I am having to post this from another PC.

I have tried everything I can think of. At first I thought perhaps scripts were disabled - they are not.

I cleared all cookies, everything, for all time, several times. And disabled everything in Brave settings I could think of - which makes it less secure than the Brave on my other machines - but no difference, so that cannot be the reason.

DNS is working ok.

Also disabled my firewall completely. No difference.

Also deinstalled brave and reinstalled several times (apt -y remove brave-browser && sudo apt -y purge brave-browser && rm -rf ~/.config/BraveSoftware && rm -rf ~/.cache/BraveSoftware)

then apt install brave-browser. No difference, problem still remains.

Plus upgraded and updated Ubuntu. No difference.

Firefox and other network applications work on on the machine, it is just Brave which has the problem.

I cannot understand what is causing this problem. It started about a week ago. All was working fine before then.

It is just the one Brave browser on the one machine. The others on my network all work fine.

Any ideas what could be causing it and what else I can try. I am getting tired of this and may just have to abandon Brave on this machine and move to Firefox.

1 Like


It turns out the machine in question has Wireguard installed. We have now switched this off, for the moment at least - and the Brave browser problem has disappeared.

So Wireguard was the troublemaker here.

Not clear to me at this stage exactly why this should cause a problem - there was no route set involving Wireguard and the VPN was not active, only a Wireguard virtual network interface was present. But once this was deleted, the problem disappeared.

And again - why was only Brave affected on that machine and not Firefox? Need to do more research into this when I have time.

Same issue here. How you fixed it?
Kde neon

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.