Brave blocking scripts on YouTube

Brave keeps blocking scripts even though I turn off blocking scripts. It just turns back on automatically. How do I stop this madness?

Hello @TKList, thanks for reaching us out. Most of the common ones (YouTube, Facebook, Vimeo) do require JavaScript to be enabled.

Keep in mind Blocking scripts can break sites, and it should be used only when you have too so if you decided to block that script or scripts it may break the site also.


I am trying to not block scripts. But the setting keeps turning it on even when I turn it off. @Jarc-1107

Hello again @TKList, if that’s the case disable it again and then clear your browsing data(cookies and cache) finally relaunch the browser or update to the most recent version. In case is not updated yet. Let us know if that resolves the issue. Regards.

When you say that the setting keeps turning on, are you referring to the setting in Brave Shields or somewhere else?

Browser is always updated. Clear cookies and restarting browser did not help:

If you go to Settings → Shields, do you have the Block scripts toggle on here?

Nope. That has always been off.

Other places you can check are brave://settings/content/javascript and see if youtube is there is set as now allowed and there is also the site permissions brave://settings/content/siteDetails? where you can see if Javascript is set to blocked there too and you can even reset its permissions there just in case.


That was it thanks. Don’t know how I managed to block YouTube JavaScript there, but it was there.

1 Like

BTW go to brave://settings/shields and set Trackers & ads blocking to Aggressive. :ok_hand:

It’s good it is working as intended now.

1 Like

Will give it a shot. Thanks again.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.