Brave Beta ads not showing up

#1

Hi!

I just downloaded the Brave Beta program (I have also tried the developer program) to try and see what ads within the browser would look like, but I don’t seem to receive any of them.

Is it a setting that’s wrong? (I have turned on the ads button in the rewards screen)

Hope someone can help me!
Merlijn

0 Likes

#2

Welcome to the Community @merlijnv :wave:

Please note that current supported country is US, UK, Canada, French, and Germany. With more support is coming.

Thanks,
:slight_smile:

0 Likes

#3

Hi Eljuno!

Thank you so much, this explains a lot! I hope more supported countries will be added soon.

Have a great day!
Merlijn

0 Likes

#4

I’m in Canada still not receiving ads.

0 Likes

#5

For anyone here still experiencing this issue, we’d like to try a few debugging techniques to see if they help us diagnose the root of the issue. If you’d like to help us capture some information on this, please perform the following steps exactly as instructed:

On Windows:

  1. Open the Windows command prompt
  2. Change directory using the following command cd "C:\Program Files (x86)\BraveSoftware\Brave-Browser-Dev\Application"
  3. Run Brave from the Command prompt with the following flags: brave.exe --enable-logging --log-level=2 --vmodule=brave_ads=3
  4. In the newly launched Brave window, navigate to: https://www.cnet.com/news/brave-promises-20x-faster-websites-with-speedreader-mode/
  5. Once you land on the site, let go of the mouse for ~30 seconds
  6. Move the mouse again
  7. Close the browser
  8. In Explorer, navigate to C:\Users\{YourUsername}\AppData\Local\BraveSoftware\Brave-Browser-Dev\User Data
  9. Double click on chrome_debug.log or open directly with Notepad
  10. Ctrl F to search for the phrase Notification not made
  11. Paste the next few words after each instance of “Notification not made” you find.

On OS X:

  1. Open up a terminal (Command + space and type terminal)
  2. Paste and run this to start the dev version of the browser with logging: /Applications/Brave\ Browser\ Dev.app/Contents/MacOS/Brave\ Browser\ Dev --enable-logging=stderr --log-level=2 --vmodule=brave_ads=3 2&>1 | grep "Notification not made"
  3. Go to: https://www.cnet.com/news/brave-promises-20x-faster-websites-with-speedreader-mode/
  4. Let go of the mouse for 30 seconds
  5. Move the mouse again
  6. Paste what shows up in the console

On Linux:

  1. Open up a terminal
  2. Start Brave in the terminal with: brave-browser-dev --enable-logging=stderr --log-level=2 --vmodule=brave_ads=3 2>&1 | grep "Notification not made"
  3. Go to: https://www.cnet.com/news/brave-promises-20x-faster-websites-with-speedreader-mode/
  4. Let go of the mouse for 30 seconds
  5. Move the mouse again
  6. Paste what shows up in the console

If present, the line you’re looking for should look something like this:
image

Please let me know the results and/or if you need assistance with any of the process above.

2 Likes

No more Ad notifications received after April 09
No Brave Ads in Brave Beta in UK - "Brave is Not Currently Supported in Your Region"
#6

I’m in U.S. currently not seeing any ads on Brave dev

ran threw the whole thing here and there is no “notification not made” in the chrome debug file.

[17008:10392:0410/012101.789:ERROR:cache_util_win.cc(21)] Unable to move the cache: 0
[17008:10392:0410/012101.789:ERROR:cache_util.cc(141)] Unable to move cache folder C:\Users\Yay mes\AppData\Local\BraveSoftware\Brave-Browser-Dev\User Data\ShaderCache\GPUCache to C:\Users\Yay mes\AppData\Local\BraveSoftware\Brave-Browser-Dev\User Data\ShaderCache\old_GPUCache_000
[17008:10392:0410/012101.789:ERROR:disk_cache.cc(185)] Unable to create cache
[17008:10392:0410/012101.789:ERROR:shader_disk_cache.cc(623)] Shader Cache Creation failed: -2

this is what i get

0 Likes

#7

On OSX there is no read out at all. Browser loads, but nothing is output after the initial command.

0 Likes

#8

I have followed the instructions, this is what I get.

Notification not made: Not in foreground
[1892:10316:0410/231307.432:INFO:client.cc(267)]

0 Likes

#9

Hey @Mattches - Right now I only get ads when I don’t move the mouse for like 30 seconds. Is this how it will be in the final version? Because I move the mouse continuously and I won’t get any ads in my daily use with the browser.

1 Like

#10

@Mattches , does this log mean anything?

0 Likes

#11

This is what I received on Windows:

[2888:19488:0416/160255.630:ERROR:external_registry_loader_win.cc(145)] Missing value path for key Software\Google\Chrome\Extensions\hdpkpbhapgfjahbajejahjjcghiclegg.
[6968:17048:0416/160256.278:INFO:refill_tokens.cc(39)] Initializing refill tokens
[6968:17048:0416/160256.278:INFO:redeem_token.cc(43)] Initializing redeem token
[6968:17048:0416/160256.278:INFO:payout_tokens.cc(29)] Initializing payout tokens
[6968:17048:0416/160256.278:INFO:confirmations_impl.cc(59)] Initializing Confirmations
[6968:17048:0416/160256.278:INFO:confirmations_impl.cc(663)] Loading confirmations state
[6968:17048:0416/160256.282:INFO:confirmations_impl.cc(720)] SetWalletInfo:
[6968:17048:0416/160256.282:INFO:confirmations_impl.cc(721)] Payment id: aa04a215-e96c-4d99-ad44-a947aff039ff
[6968:17048:0416/160256.282:INFO:confirmations_impl.cc(722)] Public key: ecf3efee6aa526961eb8614ad838653128b718a385af86ecf56e40fe7ce59042650698d696f80d0486c00dd612ef637564134e5b441315bf8440e26b9290148c
[6968:17048:0416/160256.282:INFO:bat_contribution.cc(1505)] Starts in 36
[6968:17048:0416/160256.283:INFO:confirmations_impl.cc(642)] Saving confirmations state
[6968:17048:0416/160256.283:INFO:confirmations_impl.cc(642)] Saving confirmations state
[6968:17048:0416/160256.283:INFO:confirmations_impl.cc(689)] Successfully loaded confirmations state
[6968:17048:0416/160256.350:INFO:bat_contribution.cc(1505)] Starts in 1795825
[6968:17048:0416/160256.359:INFO:confirmations_impl.cc(659)] Successfully saved confirmations state
[6968:17048:0416/160256.566:INFO:confirmations_impl.cc(659)] Successfully saved confirmations state
[6968:17048:0416/160259.671:VERBOSE1:ledger_impl.cc(1020)]
[ RESPONSE - getGrantsCallback ]

time: 1555426979
result: Failure
response: {“statusCode”:404,“error”:“Not Found”,“message”:“promotion not available”}> headers cache-control: no-cache
headers connection: keep-alive
headers content-encoding: gzip
headers content-type: application/json; charset=utf-8
headers date: Tue, 16 Apr 2019 15:02:58 GMT
headers server: Cowboy
headers transfer-encoding: chunked
headers vary: accept-encoding
headers via: 1.1 vegur
headers x-rate-limit-limit: 60
headers x-rate-limit-remaining: 59
headers x-rate-limit-reset: 1555427038
[ END RESPONSE ]
[6968:17048:0416/160332.290:INFO:confirmations_impl.cc(859)] OnTimer:
timer_id: 1
retry_getting_signed_tokens_timer_id_: 0
payout_redeemed_tokens_timer_id_: 0
[2888:9800:0416/160358.709:ERROR:ssl_client_socket_impl.cc(946)] handshake failed; returned -1, SSL error code 1, net_error -100
[2888:9800:0416/160408.846:ERROR:ssl_client_socket_impl.cc(946)] handshake failed; returned -1, SSL error code 1, net_error -100
[2888:9800:0416/160427.331:ERROR:ssl_client_socket_impl.cc(946)] handshake failed; returned -1, SSL error code 1, net_error -100
[2888:9800:0416/160449.892:ERROR:ssl_client_socket_impl.cc(946)] handshake failed; returned -1, SSL error code 1, net_error -100
[6968:17048:0416/160655.815:INFO:confirmations_impl.cc(51)] Deinitializing Confirmations
[6968:17048:0416/160655.815:INFO:payout_tokens.cc(33)] Deinitializing payout tokens
[6968:17048:0416/160655.815:INFO:redeem_token.cc(47)] Deinitializing redeem token
[6968:17048:0416/160655.815:INFO:refill_tokens.cc(43)] Deinitializing refill tokens

1 Like