Brave automatically switching from Google to Bing

Description of the issue:
Google Search Engine automatically switching to Bing when I prefer Google

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Reset search engine in setting.
Restarted Brave

Actual Result (gifs and screenshots are welcome!):
Switched to Bing
Expected result:
Stay on google
Reproduces how often:
Always

Operating System and Brave Version(See the About Brave page in the main menu):
Win7
[
Version 1.31.91 Chromium: 95.0.4638.69 (Official Build) (64-bit)

Additional Information:

Hi @RonS2 welcome to Community :smiley:

Have you noticed this issue if you switched to Brave Search?

It stays on Brave, but the results are not the same

Thanks for your reply Salty.

Sadly your solution is only a band-aid and not a fix.

Any other ideas would be appreciated.

And you have changed this setting correct? My other suspicion is a redirect virus?
Screen Shot 2021-11-17 at 3.05.39 PM

Yes I did that. I even deleted Bing from the list of options and it still switches to Bing

Still having the same problem

You might possibly have a redirect virus or malware that is redirecting you to Bing instead of Google.

I just finished doing some deep scans and there are no redirect virus.

Besides, when I said the results are not the same in Bing as in Google, Bing is still relevant just not as good.

For reference I decided to checked if to see it I’m having this same problem with other browsers.

Of the other browsers, Chrome, Edge and Firefox NONE of them switched to Bing when doing a Google search.

While doing a Google search in FireFox I found that this problem is a common occurrence with Brave dating back years. This is a bug that needs to be fixed.

I did find a workaround that cured this problem
https://support.google.com/chrome/thread/47617506/my-default-search-engine-is-google-but-the-url-redirects-me-to-bing-yahoo?hl=en

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.