Brave automatically linking Paypal through Russia

Whenever I go to “paypal.com” it automatically sends me to “paypal.com/ru/home”. I’m in the U.S. What’s going on? Ideas? Doesn’t happen on chrome browser.

1 Like

Clear cookie on PayPal then refresh and try

It may happens because you have used VPN in past

Regards

@WVJW

Clear all the cache, cookies, history, and site data that can - but with respect for what you believe that you need to retain.

Go to: brave://settings/shields

Default view: Advanced view

Disable: Auto-redirect AMP pages

Go to: brave://settings/content

Scroll down to “Content” . . . and set:

  • Pop-ups and redirects: Don't allow sites to send pop-ups or use redirects

Close the window and Restart Brave Browser.