Brave asking for password when opening link but it is already running anyway

Description of the issue:
Brave is still asking for password to run it after clicking web link in an email (Thunderbird), which is totally useless because Brave is already running.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Boot into notebook as usual until desktop (KDE) seen (OK),
  2. Run Brave browser, browse to any website (OK),
  3. Run Thunderbird email client (OK),
  4. In an email containing a link that is opened by browser: click this link to be opened with Brave (OK).

Actual Result (gifs and screenshots are welcome!):

  1. BUG: Brave is asking for main Brave password, but it is already running (NOK).
    image

Expected result:

  1. Because Brave is already running no password should be required, link should be opened in Brave straight away.

Reproduces how often:

  1. Always.

Operating System and Brave Version(See the About Brave page in the main menu):
Version 1.46.153 Chromium: 108.0.5359.128 (Offizieller Build) (64-Bit)

Operating System: Debian GNU/Linux
KDE Plasma Version: 5.26.5
KDE Frameworks Version: 5.101.0
Qt Version: 5.15.7
Kernel Version: 6.1.4-1-siduction-amd64 (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i5-8350U CPU @ 1.70GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
Manufacturer: Dell Inc.
Product Name: Latitude 7490

Additional Information:
Important:
The password is not even necessary to be entered, the website will be opened even without that, so the safety password entry is totally bridged or useless. I have found this by accident after doing a screenshot of the password entry window and then selecting KolorPoint for editing it.

1 Like

Hello there @Colrin, thanks for reporting this issue. Try disabling your extensions to see if this is the cause of the issue.

  1. On your computer, open Brave.
  2. At the top right, click MenuMore toolsExtensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.

Step 1: I have removed Zoom Meeting extension and ublock ad block extensions, so no extension installed anymore.
Step 2: in Thunderbird, I click a weblink in a mail. Brave should be opened.

Still Brave asks for password, so removing/disabling extensions has not helped at all.

1 Like

Hello there @Colrin, on this case try installing the Beta or Nightly version of Brave to see if the issue persists on those versions.

Hello,
I have removed brave standard browser and installed beta instead. Same issue seen.

1 Like

Is Brave set as your default Browser? if is not, please try setting it to see if that makes any change, additionally try opening those links on a different Chromium based Browser to see if the issue persist.

Yes, Brave is set as default browser.
I have installed Chromium, which says it is not able to change default browser, so it is useless for this test.
I have also installed Google Chrome which is now default browser.
Thunderbird still opens kwallet to request Brave password.
Thunderbit has an issue with changing app to open html (website) documents. It is not asking for application to use if set to “always ask” which appears to be a bug in Thunderbird. But even if default browser no longer is Brave it still opens kwallet to request Brave password.

Hello @Colrin

when you open brave (not throw email link) does it also ask you for password?
did you configured it to do so?
and how ?

Hello,
the Linux distribution that I use (siduction) has kwallet pre-installed as password manager. When I open Brave (no Thunderbird running, Brave not running before) I get that screenshot that I have attached with my initial description (Brave is requesting password via kwallet). So, yes, Brave is asking me for password. I myself have not configured this procedure, it came pre-installed with my Linux distribution.

What worries me here is that kwallet does not even contain an entry for a Brave password. It contains a folder named Brave which indicates it tried to store something, but it contains 0 passwords. So the whole process appears to be totally useless. But it makes a difference to enter password as requested and not doing so and simply skipping, as when I skip password entry I loose my previous session that Brave used and e.g. loose playback position of a youtube video. When I enter password I get the position of playback that I had before I closed Brave.

Now I’ve tried this:

  • In running Brave, open a youtube video and let it play.
  • Close Brave while youtube video is playing,
  • open kwallet and leave it open (requires main password entry)
  • delete Brave password folder entry (which contained 0 passwords actually) in kwallet,
  • run Brave (needs no password this time)
    ==> youtube is logged in, playback continues at same location where Brave was closed.
    ==> The whole process of Brave asking for password and placing password in kwallet is corrupted somehow. I am not even sure if this is an issue of Brave at all.

Hello @Colrin

thanks for the extra details i think it something related to kwallet but did you tried to open brave using links in the Thunderbird email client after you removed brave from kwallet?

i have no knowledge about kwallet so maybe when certain app does not have password it force you to use some kind of default password but i am not sure of that i guess you need to dive more into that

@Colrin,
Are you able to reproduce this issue when using another browser? If you could test using another Chromium based browser that would be ideal.

@Colrin,
Apologies — I missed where this test was already performed above. Given everything I’d say this is in issue related to kwallet rather than Brave specifically. Is this the same kwallet you’re using here? https://apps.kde.org/kwalletmanager5/

If so, have you reached out to/looked through the support options there?

If you are redirected to kdewallet with every link you try to open in Thunderbird, independently of the browser you set as default, it may be an issue with extension configuration.
Likely the web extension html or others are associated with kdewallet, not the browser.
Check your extensions config. I cannot help as I do not know anything about Debian.

Yes, that’s the one. And I have filed an issue report to kde team for kwalletmanager. No feedback so far, though.

I have checked which application is handling html extension, and it never is kwallet nor kwalletmanager. It is handled by brave browser.

Actually, I am not surprised by that as in the description of the issue I had already described that weblinks (html etc.) are passed on to brave which then requests kwallet manager to open password wallet.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.