Brave app showing ads that are not in my region and obviously not getting count

Please @Mattches @steeven I request you to address this problem. Because this is eating a lot of our ads on brave android app.

Here is a video. You can do this the same in Windows 10.

I believe that @rosiecar is correct here – I don’t think there is a way to change your Android system settings to en_IN at this time. That said, this is likely the issue, but it would be useful to test the theory – can you try setting the language setting on Android to match the region you’re located in and just see if this is in fact the issue?

User is seeing these issues on Android – nice gif though :slight_smile:

Actually, you can. In Android 10 and older versions, you can change your region location and keep the same language on your device, no problems will happen, its that easy peasy!

P.S: Ugh, I hate Microsoft store, I can’t find any high quality screen recorders, thus I won’t use popular editors like Filmora X, as I have 17 GB of storage.

Very interesting – although I imagine OP is on a later version.

Also, ScreenToGif is a good one:

I actually have seen a phone with Android 10, and you can search some options, for example, you can search region settings and you could change the region in those region settings. Also, thanks for the screen recorder recommendation!

Damn, I searched for region settings and it was already set to India. So now, my language is set eng-US and my region is set to India. So where the glitch??? @Mattches

It is probably a bug, the only way to get BATs is by using a VPN.

P.S: I forgot to mention for now.

This indeed is a bug. @chirag_soni_07 try to change your phone’s default language to Hindi. It worked for me. I am trying to look other options. Do post an update.

1 Like

No, changing your language only changes how the apps are named, changes the language of the app, and more, changing the language does NOT apply to the region settings.

Mat is right here. See this for more clarity-

In Video, notice my initial earnings and how they did not change after viewing an NTP Ad that didn’t belong to my region. After changing device language, NTP Ad came from my region and my earnings increased for viewing it. Recognises the region as set in Device. Notification ads too belong to the Device Region. But NTP ads are recognising region as set in the Device Language. It may not be a bug but design to work this way but this is not how it should work.

I tried to change my language to English (India) but it is not available in Device Language (just like Mat said) and I couldn’t find any other way. Only keyboard language can be changed to en_IN


This is the last time I am gonna say this, for God’s Sake, you can change the language but it doesn’t apply to the region settings, thus, en_IN works on everything, language only changes the name of the apps, how the app’s language is, etc. If en_IN does not work on your device, then try to upgrade to a more later version, for example like Android 10, then test it out and see if it works. if you are already on Android 10 and it is not working, try upgrading to Android 11, if that doesn’t work also to use en_IN, then it is probably a bug. Also, I would strongly suggest you back up all of your data, just in case.

Daaaamnn, lemme try.

@Aman_M yeah man, you’re right. It works for me too, but isn’t it ridiculously funny, getting ads based on your phone’s language. @Mattches @steeven please look into it. We can’t change our habit of using english on devices just to get NTP ads. Plus, this is not an issue in desktop. So why app?

This actually does appear to be an issue in our implementation. I’ve brought this up to the Ads team and we are working on a better way to go about evaluating criteria for supporting ads in different regions:

1 Like

Hi @Mattches , another update.
My phone was also showing eng_IND option, but that did not work. Only HINDI worked.

English (UK) also works for me.

1 Like

@Aman_M thank you so much man!! Eng UK worked for me too. Can’t express how much of help this was. Thank you again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.