Brave always redirects http://localhost to https://localhost even though nothing is there

https

#1

I have a problem with “HTTPS Everywhere” and sites I run locally using localhost.

It started when I was tinkering with an nginx config, that wrongly redirected all traffic from HTTP to HTTPS. I have not set up certificates on my local machine, so this produced an error. I quickly fixed the issue, by not redirecting when running on localhost.

However Brave seems to remember this redirect, and now ALL requests I make to localhost (, or http://localhost:3000), it somehow automatically redirects to https:// localhost, which doesn’t work or even exists. This happens even if I don’t have any server running or anything. My sites work perfectly fine in Chrome, it is only Brave that keeps redirecting me to HTTPS all the time.

Opening a Private Tab makes it work, I am then allowed to access http:// localhost without any redirects.
As I’m always shown an error page, I cannot disable the Brave Shields for http:// localhost, as it seems you cannot change Shield settings for error sites. At least I can’t. I can easily change Shield settings when using a Private Tab, but of course these settings won’t be remembered outside the Private Tab.

So, what is my next move here? I’m hoping that I don’t have to delete all browser data, that would really be a bummer.

  • Operating System: macOS 10.12.6
  • Brave: 0.19.139
  • rev: 99aa17da28e040543b4ba217d2c4dd6633bf1446
  • Muon: 4.7.2
  • libchromiumcontent: 64.0.3282.85
  • V8: 6.4.388.20
  • Node.js: 7.9.0
  • Update Channel: Release
  • OS Platform: macOS
  • OS Release: 16.7.0
  • OS Architecture: x64

#2

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.