Brave always creates a debug.log file in my Desktop

As the title says, Brave always creates a debug.log file in my Desktop (version 1.17.75 on Windows 10). The file can only be deleted after I close Brave.
At the moment, the content of the file is
[1206/151318.251:ERROR:directory_reader_win.cc(43)] FindFirstFile: Impossibile trovare il percorso specificato. (0x3) (it’s in Italian)

@gmacar,
Can you search on your system for a file called BraveUpdate.ini and see if you have one somewhere?

@Mattches BraveUpdate.ini does not exist in my C: drive…

@gmacar,
It actually looks like this is an issue for lots of people – seems to be inherited from Chromium:


:point_up: This bug report states that the issue should be resolved in what appears to be the next Chromium bump – Brave will inherit this change as well.

For the time being until this is fixed, is it possible to make it put the debug file somewhere else so its not clogging up my desktop?

This bug is really annoying :rage:

To confirm, @CrossedLemur @gmacar – you’re still getting debug.log files after closing Brave every time?

It seems like the problem has went away, I sent that original reply while I was on vacation without my computer because I wanted to know how to fix it for when I got back.

1 Like

At the moment I have a debug.log on the desktop, created (or modified) on 01/01/2021. I’m going to delete it and I’ll post here if it gets created again.

1 Like

@gmacar,
Please do – I’m in contact with a couple devs who may have more information.

For me, the problem startet occuring since I use the --app parameter to launch some web-apps

debug.log has reappeared today.
Content:

[0106/175157.839:ERROR:directory_reader_win.cc(43)] FindFirstFile: Impossibile trovare il percorso specificato. (0x3)

@gmacar,
Have you ever enabled logging before or have you changed your group policy settings at any point? Further, can you ensure that there are no command line args attached to the end of your Brave browser application?

You can do this by right-clicking on the shortcut you use to open the browser, then click Properties and check the Target path – ensure that it does not end with anything that looks like --enable-logging --v=1?

I’ve never changed any settings or files.
The shortcut launches "C:\Program Files\BraveSoftware\Brave-Browser\Application\brave.exe"

1 Like

the problem is back now

1 Like

Hey there folks! There is a fix for this which will be coming in our 1.19 release on Jan 19th (which features Chromium 88). The upstream bug and details are captured here:

Apologies for the inconvenience. It should be fixed on Nightly and will be working through Beta soon before the 1.19 release happens