Brave Ads Work! But Brave Rewards do not Work! Brave and Brave Beta rewards are broken and do no accumulate any more on MacBook MacOS. Help!

Briefly describe your issue:

Ads WORK, but no Brave Reward! Repeat Ads work, but no reward. Brave Browser STOPPED giving rewards for me in March 2020 on my MacBook laptop. I switched to Brave BETA and it worked and I have received rewards ever since. This past week, Brave BETA stopped giving rewards. The amount froze. So, today, I downloaded the latest Brave Browser ( not beta) and rewards do not increment, they stay at zero while ads continue to display. Ads display as expected, but the rewards do not increment.

My previous bug report the team was focused on Ads. This is not about Ads.

What Operating System and Brave version are you using ( Menu --> About Brave )?
Mac OS Big Sur 11.6
Version 1.33.77 Chromium: 96.0.4664.35 (Official Build) beta (x86_64)
](https://brave.com/latest/)

Is your browser wallet currently verified? (yes/no)
yes

What date did you verify your wallet?
Couple months ago.

Have you been able to successfully receive payments in the past?
yes

Are you using a VPN? (yes/no)
no

Are you in a supported region (see here for list of supported regions)?
yes

Does your device pass the SafteyNet check (Android only)?
Not applicable

Have you manually turned off Auto-contribute on all of your devices linked to Uphold??
Yes

Your help is appreciated. Thank you.

There is clearly a bigger problem that hasn´t been adressed yet, I’m still waiting to see what happens.

1 Like

Hi @mkneisler, welcome to Community :smiley:
Can you please DM me your Wallet ID (found at brave://rewards-internals)

Hello @SaltyBanana, I sent you my wallet ID but you didn´t reply back, could you take a look, please?

Hi @Temp1010 could you send another DM, it looks to have been received.

Any updates, action or suggestions to get the rewards working again?

Updated to latest Brave, but NO JOY.


Version 1.33.87 Chromium: 96.0.4664.45 (Official Build) beta (x86_64)

Unfortunately, multiple wallets have been flagged. You could try contacting the staff (and be patient) or reinstall the browser and try again.

Thank you. Here is the interesting part. Maybe this helps others who are frustrated with Brave reward performance on MacOS. I have connected my Uphold account to another PC. This PC (Windows 10) works perfectly. Ads show, rewards accumulate. All as expected and all good. The wallet, the Uphold account are properly accumulating rewards with NO interruption or problem. If the wallet is corrupted/compromised/problematic, then why would it work on MC but not MacOS? Thanks again for the interest and support. Cheers.

Here are details on the PC: Brave version 1.32.113 Chromium 96.0.4664.45 (Official Build) 64-bit)