Braqve crashes on launch


#1

Brave tries to launch, white screen pops up for a split second and then closes, nothing else happens. Using Linix Mint 18, please help, thanks


#2

I’m having the same issue.
Ubuntu 16.4 LTS.
Last thing I did was activate MetaMask, set up a new Ethereum wallet, then import some wallets from MyEtherWallet.com, including a lot of ERC20 tokens. After a re-boot, I discovered Brave not starting. Same symptoms as original reporter,. A white screen, then quickly nothing.
I suspect authority issues which I may have messed up.

Please give a run-down of every file and directory Brave touches/looks at/uses/needs and what the owner and authorities should be on each and every one of them.

My groups are:
joe@joeslinux:~$ groups
joe adm cdrom sudo dip plugdev lpadmin sambashare

I am the superuser and, I am the only user, setting up the “joe” account when installing Ubuntu.


#3

@dragon1 and @JoeM

Are you both using snap as in this post? Brave immediately crashes when I try to start it. It pops up and then closes

Thanks,
Lauren


#4

Hi Lauren,
Yes, I am using Snap. Although I must confess I don’t know what Snap is. It just appeared on my installation. I’ve been meaning to investigate that.

joe@joeslinux:~$ cd snap
joe@joeslinux:~/snap$ ls -al
total 20
drwxr-xr-x  5 joe joe 4096 Mar 28 21:36 .
drwxr-xr-x 50 joe joe 4096 Apr  5 07:46 ..
drwxr-xr-x  5 joe joe 4096 Apr  4 23:15 brave
drwxr-xr-x  6 joe joe 4096 Mar 28 18:08 gnome-calculator
drwxr-xr-x  5 joe joe 4096 Mar 29 07:26 telegram-desktop

joe@joeslinux:~/snap$ cd brave
joe@joeslinux:~/snap/brave$ ls -al
total 20
drwxr-xr-x 5 joe joe 4096 Apr  4 23:15 .
drwxr-xr-x 5 joe joe 4096 Mar 28 21:36 ..
drwxr-xr-x 5 joe joe 4096 Mar 28 21:37 18
drwxr-xr-x 5 joe joe 4096 Apr  4 23:15 19
drwxr-xr-x 3 joe joe 4096 Mar 28 21:36 common
lrwxrwxrwx 1 joe joe    2 Apr  4 23:15 current -> 19

#5

Thanks @JoeM! I have logged an issue for development to investigate:

Thanks,
Lauren


#6

Thank you. What’s puzzling it that it had worked for a while before without issues.


#7

We recently released an updated version of Brave, 0.22.13. Although, I can’t reproduce this crash on launch when I install outside of snap, so could be snap related. Either way, development will review the issue. The most up to date information will be available on the logged github item, so I’d keep an eye on that :slight_smile:

Best,
Lauren


#8

Hey Lauren, although I’m a Linux user I am not that techy. Also I have been using Brave for at least 6 months and cant recall what way I installed it ie:was snap used for install. I can check if you tell me what to do. Thanks


#9

I’m also affected. Brave won’t run and I only get this:


#10

After upgrading and restarting Ubuntu it works here


#11

I am not an expert on linux but it appears that they forced it back to the previous version because it works for me now but snap reports that it is running:
v0.21.24dev 18 brave
instead of
brave v0.22.13dev 19 stable brave
which was the new version that was crashing.


#12

You’re right, I forgot to check that out.


#13

Hi Lauren and team,

  Brave Browser started with no issues tonight. I did not do

anything to it.

  However, I was doing quite a bit of maintenance to my Ubuntu. I

installed a proper driver for my graphics card. I installed an
Ethereum miner and a Monero miner. Both of which involved apt-get
install, update, and upgrade. Could I have upgraded the Snap
software you had enquired about? Just a thought.

I’m quite surprised but happy Brave is launching again.

  If your technical team wants to home in on what happened, I'll be

glad to offer whatever assistance I can.

Regards,

Joe


#14

Hi @JoeM

We rolled back to the previous version in snap since 0.22.13 was crashing. The team is still working on resolving this snap related issue :slight_smile:

Best,
Lauren


#15

I have the same issue.
linux mint 18v3

Brave v0.22.13dev 19

Is there anything I should be doing to resolve this or just wait.
And when the techies resolve the issue do i need to uninstall Brave and re install it?


#16

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.