Bookmark Sync is not syncing

I tried to sync my computer to my new Android phone on December 15, 2019. On my computer both devices are in the Sync chain but as of today my Android phone has not imported my book marks. Any assistance would be greatly appreciated.

1 Like

Same here : unable to sync from Windows to Android or the other way. All settings are OK but no sync.

Too bad this simple feature that bugs from the beginning of this year…


Agreed. You would think. And I’m surprised that something as basic as this would not even get a nod on this bulletin board from a Brave tech person.

Ever since Chromebooks came out, I was a big fan of Chrome, until I discovered Brave, their built-in Ad Blocker, increased speed and BAT currency. OTOH, Chrome was always reliable in terms of syncing between devices and computers. And with some Ad-Blocker extension, there was no difference between Chrome and Brave. I have tons of bookmarks, settings and histories; like yourself, I had to cut back ( to Chrome in my case ) until the Brave sync fails.

Hi jsecretan: Here’s a screen shot of the brave://sync from my browser:

. I press “I have a Sync Code” button and enter the chain code: here:
But when I finish entering the chain code and press “Confirm Sync Code” , nothing happens. There is no change in the page, no reaction to when pressing the button. The code just remains in the box, and pressing the “Confirm Sync Code” gets me nowhere. Pressing “Cancel” is the only thing that gets me out. I came back to this bulletin board hoping was fixed ( This once worked a couple of months ago ), but no longer. This is even worse than the “Bookmark Sync is not syncing”

I guess by the length of time passed by on this topic, that there will be no fix in the future. No worries. Our bad. Have to adapt to the failures of others.


I had a sync chain between 2 linux PCs and Android device at some point started to realize that it doesn’t sync anymore, had to remove and start chain again.

1 Like

Just reinstalled windows and my Synced bookmarks are 3 weeks outdated or thereabouts. Can I fix that or they are lost forever?

After update have all my bookmarks gone. Few days along Ive saved my syn code (words). Ive tried to use it to recover bookmarks but it says there is too few words in the code. Any help?

Just started the chain from my computer to my phone. The phone doesn’t show any bookmarks at all.

1 Like

After pasting code copied from first machine, clicking on ‘Confirm Sync Code’ has no effect.

Pressing Enter key has no effect.

Both machines up and connected by wire to same LAN and can otherwise communicate via SSH, telnet, NFS and so on.

Version 1.2.42 Chromium: 79.0.3945.117 (Official Build) (64-bit)
Ubuntu 19.10 up to date.

Also for @HappyHappy

I had this issue for years and figured it out a few months back. This is a completely different issue from OP/Syncnot syncing bookmarks over time.

You need to delete and/or recreate the Brave profile you are using. I created a new one and it worked right away

@Brave this is 2020, not 1920 where pigeons carry messages for a long lost letterbox. Bookmarks are a standard function of browsers.

Seriously the most basic function of a browser and it doesn’t work. I’ve supported Brave, I own BAT - but going to sell everything. I’m tired of this. Thank you, downloading Firefox as I type…this… there…we…go… upload bookmarks… CYA


Team Brave, this is untenable!

I’m having the same issues here. One PC desktop, one surface book 2, one samsung s8. They are not syncing bookmarks effctively at all. I arrange them on the desktop… half gets done on the laptop then stops. the phone doesn’t even know what’s going on.

I need to restructure my bookmarks weekly. My work is online and I use only browsers to work. I love Brave, I love BAT, I love the Shields, but I will have to abandon ship if this isn’t sorted in the next week or so!

(example, I have folders of bookmarks, with 8-11 in each. wherever I need to work on a specific project I right click and open all tabs in folder in a new window - can you imagine if that folder is not the same on each device each time… or worse the folder doesn not exist on this devide. Its literally impossible for me to work. Bookmarks are not heavy data. They should sync in millisecs…


Many thanks and best regards


Totally agree and the real joke of it, they don’t even acknowledge it as a “Known Issue” on this forum -

I have 5 different installations of Brave split between Windows and Android, and none of them sync identically and I have to keep exporting/importing them manually.



yeah I’ve now exported latest bookmarks from Brave and got the structure back into chrome again. about to minimize the amount in brave and see if that helps. if not i will de-link all devices and start from scratch to give it a last shot… otherwise i’ll shelf brave for now sadly

1 Like

Ok I had a pretty serious go at this today, at the cost of my time, trying to make a modern interwebs browser sync some hyperlinks (aka URLs and/or bookmarks).

So i have three devices. I deleted all book marks on laptop and phone and unlinked them from the sync chain. I reorganised the bookmarks in Brave on my desktop to a few main folders, so it would be easy and quick to delete on other devices if my trick didn’t work. I then exported my new cropped down book mark structure to drive so i have it safe. I then deleted all bookmarks on the desktop PC as well. Now I had 3 clean devices, unlinked from each other. I proceeded to import the new 200 or so bookmarks from file into Brave on the desktop and then linked back the phone and laptop via QR code and 24 word key.

Did it work? Nope.

The phone, over 20 mins or so, took about 25% of the bookmarks, disregarding folder structure… i.e. some bookmarks were taken individually, a few folders were complete and some empty. complete hotchpotch. Unusable. Unworkable and completely baffling.

The laptop, wen’t a stretch further. It actually found the original mess of 6 month old, unsynced and messed up bookmark structure… not related at all to the one i just imported to the desktop PC.

I am not a database engineer but I dare to say there that “something ain’t right in Denmark” on this one. I’m going to do the same test on chrome now. My money is on that it will work immediately. If so, im back on chrome until Brave can sort this.

have fun ya’ll

1 Like

ok Brave on all three devices are, as we speak, in quarantine. The correct structure only exists on my PC desktop at the moment and no sync chain is established between any devices. The other devices are clean of any bookmarks.
So i’ll wait a week or so going back to using Chrome.
Perhaps there’ll be a database mop up in a a few days or a week, and then I can try to relink the other devices and see if i get a clean sync.

Will update

I am encountering the same issue: where you’d expect all devices to have the same list of bookmarks being in the same sync chain, they are all different. 1 Android device and 2 laptops and 1 desktop.

having the same issue just bumping this. very hesitant to use brave bc i liked the way chrome sync’d history between devices–the bookmarks too is kinda adealbreaker

Same issue here, nothing changed in a year - I reported it last year as well. Like few others, I, too, have moved back to Firefox/Chrome and only use Brave out of curiosity. There is a potential for it to be the main browser for many but, without basic working feature like bookmarks sync, the potential is far from realized. Will check again next year, but for now, back to Firefox.


The is a lot to love about Brave browser, but the bookmarks in general and sync in particular is really awful and needs a lot of work. I’m having the same issue as others, namely:

  • Syncing being unreliable and generally causing issues
  • Sort order of bookmarks changes seemingly at random
  • Bookmark icons disappear if the bookmark is moved or synced

To top it all, the latest release of Brave has disabled sync altogether. Unfortunately at this stage I don’t think that Brave is ready for release to the general public. It’s early Beta quality at best. Before anyone asks I have tried to uninstall and delete all personal data and then reinstall, but the issues remain.

[Version 1.3.115 Chromium: 80.0.3987.87 (Official Build) (64-bit)]