Bookmark import failed

Description of the issue:
I try to import bookmarks and it fails
How can this issue be reproduced?

  1. At home screen, tap … menu at top right
  2. Tap Bookmarks
  3. At bottom left, tap Share icon
  4. Tap Import Bookmarks
  5. Locate HTML file of bookmarks on the iPad and tap it
  6. Error box appears: Bookmarks – Bookmark Import Failed – OK

Expected result:
I expected the bookmarks to be imported into my Brave browser.

I tried to import a small set of bookmarks saved from these browsers: Chrome, Edge, Firefox and Safari. Even when I tried to import bookmarks that I had just saved from Brave on this device, it failed.

This is the same behaviour as was reported by @bob_mv in December 2022.
Sadly, his report was automatically closed for comment before anyone could respond.

Brave Version( check About Brave):
1.47 (

Mobile Device details
iPad Air (3rd generation)
Model MUUK2X/A
Software Version 15.5

Additional Information:
I agree with Bob that extra detail is needed in the error message – what caused the failure?
I went to the github site for Brave and searched the Issues there, but couldn’t find anything about this problem.
Hoping some generous person can help :slight_smile:

1 Like

Hello there @JimH44 please accept my apologies for this issue.

Could you please try deleting your cookies from the app to see if the issue is solved?

  1. Launching Brave, tap MenuSettings
  2. In the Features section, tap Brave Shields & Privacy
  3. Clear private data > Cache - cookies and site​ data > clear data now

Let me know if that works.

Thanks, @Kevin_cc , for your response.

I cleared that data as you suggested, but still get the same error:
Bookmark import failed

Next I removed the program completely and all its files, and then reinstalled it.
Before I did anything or went to any website, I tried the same procedure to import bookmarks, with the same error message.
Even the HTML file that I had exported from Brave could not be loaded. Same error message.
Could you make a message that reports what went wrong in the import?

1 Like

We’ll try to fix it in 1.48, sorry. It broke some time ago, we fixed it and it seems broken again.
Something weird with iOS file system access

1 Like

Great news, @michal :slight_smile:
Is there a way I can be notified when 1.48 comes out?

1 Like

I’ll ping you here :slight_smile:
I hope we can fix it today, and the 1.48 build should go live by end of this week

1 Like

Hello, the iOS 1.48 is out in the App Store. Please give it a try and let us know if the problem is resolved :slight_smile:


Congratulations @michal !
I saw the message “Bookmarks imported successfully” :slight_smile:
The bookmarks now work very nicely for me, when I tap the elipsis menu and then tap Bookmarks.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.