Blue bar above tabs shows up suddenly

There is a bug that occurs when I switch to brave browser window and put it in focus. Criteria is for taskbar to be on top and icons to be set on small.

All of the sudden, tabs will be pushed down and blue bar will arise at top: https://imgur.com/a/SdK2IcN

I suspect color to look like my chosen windows 10 theme color, but im unsure about this.

This person has the same issue(unfixed): https://www.reddit.com/r/chrome/comments/8r6ibl/blue_trim_bar_on_top_of_chrome/

@Mattches any ideas? Ever seen this before?

Did the solution in the Redddit post work for You?

@Dgenies

Nope. And “chrome://flags/#windows10-custom-titlebar” flag has been removed from chromium some time ago.

Also, this is a strange issue because many posts on google say how this is a fix for a thin colored line at top of the browser’s edge, not a bar. So changing that flag doesn’t make much sense to me.

@blackturtle,
I believe that this is known and we’re currently deciding how we’d like to handle this particular link between system theme and the browser:


@Mattches

yeah, but this blue bar is frequently appearing and disappearing by itself for short period of time, tilting up and down while it transits

@blackturtle,
Would you mind sharing an image or a short screen recording of the behavior as you see it on your end?

@Mattches

Looks exactly like this: https://imgur.com/8YY3RJt

@blackturtle,
To test – if you go to Windows Theme Settings and change the Window title bar accent color (or turn it off), does the bar go away?

@Mattches

That feature has already been disabled for me, way before I installed Brave :confused:

@blackturtle,
Oh really? That is…very strange.
Do you have any Windows theme settings configured or is it just default?

@Mattches

default theme and colors, didn’t change anything! However, maybe my taskbar being at top and icons set on “small” causes this bug?

Its as if brave doesn’t know about taskbar being smaller when icons are set to small, and tries to fill the gap with that blue bar while resizing itself.

1 Like

@blackturtle, are you by chancing using more than one monitor? The description/image matches

That’s the bug! However, I don’t have 2nd monitor. Thanks for the update! <3

What was the cause if I may ask? :slight_smile:

1 Like

@blackturtle,
I’d recommend turning off Hardware Acceleration in Brave just in case and it’s an easy check to see if it helps resolve the issue.

If not, I have a couple tests if you’re willing:

  1. Can you try downloading (if you haven’t already) Brave Beta, Nightly or Dev builds and after installing, see if they display with the same blue bar?
  2. Can you download any other browser (preferably Chromium based – Chrome, Vivaldi, Opera, are good examples) and see if they display in the same way after install?

I tried it for ~15 minutes without hardware acceleration and it seemed gone. However, i believe it needs more testing. I have presentation for work tomorrow and I just can’t play with it right now. Perhaps this weekend

1 Like

@blackturtle,
No problem – please let me know what you find out.

@Mattches

It seems browser works fine without hardware acceleration! I will keep this post updated if anything changes. It seems the bug comes from hardware acceleration system and hits chromium as well. And I would REALLY prefer to use hardware acceleration feature.

I have my intel gpu integrated into processor on my tower, alongside my beasty nvidia gpu. However I believe my intel gpu is disabled.

I have also noticed that new windows open in maximized which is great! This is sadly not the case when hardware acceleration is enabled. Are there any plans to address this so that new windows on hardware acceleration can start maximized?

Cheers! :smiley:

This topic was automatically closed after 30 days. New replies are no longer allowed.