Blocking pop-up menu

bug
#1

Hi, guys, here’s the thing:

sometimes when right-clicking on a banner and getting a menu with the option to block using a selector, the pop-up, where the selector should be put into, doesn’t appear.

I’ve noticed that this issue is reproduced only when:

  1. A different selector was blocked before
  2. You are still trying to block something on the same page (refreshing or re-entering the page doesn’t help)

It just seems that the action is dropping dead.

I think you understand that the ability to enter a new selector should be possible in any logical means, but it’s not there. The only thing that helps is closing ALL Brave windows and re-opening them again.

Found no way to find the logic behind it, but it keeps bugging me (didn’t try it on any other OS/distros though).

I’m running Windows 10 1809 17763.316 desktop, Brave Version 0.59.35 Chromium: 72.0.3626.81 (Official Build) (64-bit)

I know that the report is a bit murky, but I wasn’t able to isolate the issue. Hope this helps :confused:

0 Likes

#2

@pleshij,
Thank you for reaching out to us.
I think I understand what you’re saying, but would you be willing to share a short recording of the behavior?

Also, are you referring to the Brave built-in CSS selector ?

0 Likes

#3

I salute you, oh Brave support person!

Yes, I was referring to the CSS-selector, but… how to put it?

Sorry for waking you from your slumber, oh mighty one, but it’s quite awkward and stupid:
I’ve selected the option of preventing the page of any further dialogues. But it turned out that this feature prevented the browser’s CSS-selector dialog, not the page’s dialogues. And the strange thing is that when restarting the browser (as mentioned above) it still allows browser dialogues.

Not sure if it should work this way, but if it’s supposed to behave this way, then you may unkudo me :’(

P.S. Still need a video? :smiley:

1 Like

#4

Okay, nevermind, I guess I need some sleep, I understood my own level of stupidity and feel ashamed, thanks for your time though :tired_face:

No issue here

0 Likes

#5

@pleshij, don’t be so hard on yourself!
This exact issue has happened before so you’re not the only one. If I recall correctly, you’ll need to close/quit Brave and reopen to enable the dialog box again.

0 Likes

#6

Yes, that’s exactly how it goes, but on the other hand.

But how did I understand that I’m fooling around:

  1. I block dialogues for the page (which are basically alert();) that are performed via browser
  2. I trigger an alert() by selecting ‘Block via [CSS] selector’ (which I have prevented from being here)
  3. The Alert() pops up
  4. The browser blocks it, because GOTO 1
  5. No CSS-selection pops-up
  6. PROFIT!!!

I’m not sure about it, if it should use the preference permanently (write it in some .ini or smt) or have a UF ability to unlock this particular decision made in 1.

But that’s more of an UX feature, I’m not so strong in this discipline, to say at least. I’m not even sure if it’s a bug or feature :smile:

0 Likes

#7

Honestly its not a bug or a feature - its just unfinished :slight_smile:
Still lots of improvements to be made on that feature, including a way to ensure you don’t block your own modal!

1 Like

closed #8
0 Likes