Blank in non private browser

Description of the issue:
Website is rendered blank when using non-private browser. Private window renders it without an issue. Tried all kinds of combinations of disabling shields (locally for the website and globally in settings neither of which helps). Edge browser also renders website without an issue.

Steps to Reproduce (add as many as necessary):
Launch Brave
2. Visit in non private window

Actual Result (gifs and screenshots are welcome!):
Rendered blank website

Expected Result:
Rendered complete website.

Reproduces how often:

Brave Version(See the About Brave page in the main menu):
Version 0.64.77 Chromium: 74.0.3729.169 (Official Build) (64-bit)

Additional information:

Thanks for reaching out to us!
Looking on my end, using Win10, I can reproduce this – however, when I Allow trackers or drop Shields entirely, the site renders without issue:
(sorry for the slowdown issue at the end there – Windows auto-rebooted seconds after the video stopped :slight_smile: )

Not sure why you don’t get the same results. Can you try clearing site data and trying to view the site again?

  1. Visit and click the “lock” icon on the left side of the address bar
  2. Click Site Settings
  3. Click Reset Permissions and Clear data
  4. Refresh the website when prompted
  5. When presented with the blank window open your Shields panel and
    • Try toggling 3rd-party trackers blocked off
    • If the issue persists, try lowering Shields entirely

Let me know if this resolves your issue.

@Mattches Thank you for looking into the problem!
Tried clearing the site data, resetting permissions and allowing only 3rd-party trackers with no luck :frowning:

The problem still remains. The Brave installation is pretty fresh, as you can see from the Windows specifications, so I’m not sure myself where could be a problem

Do you have any extensions installed? If so, try with them disabled and see if behavior changes.
Additionally, can you try creating a new user profile – use the Manage people option:

Try to visit in the new profile. Let me know what you find out.

Found it! Extension in question was Windwscribe VPN even though it was not engaged. I didn’t know that it has and AdBlocking component as well :smiley:. I changed it so that it has access to a website On click and now the site renders correctly.

Thank you very much!

1 Like


You’re very welcome!