Black screen while watching streams on twitch with Adblocker Ultimate On

Description of the issue:
Randomly my Twitch web screen turned black and now I can’t see any stream
I tried watching it on Edge it worked fine
So I tried not to use the Adblocker Ultimate extension and it actually started working

Exact URL of the website in question:

Did the issue present with default Shields settings? (yes/no)

Does the site function as expected when Shields are turned off?
No still the same

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):

Does the site work as expected when using Chrome?

Brave version (check About Brave):


If it works with Adblocker Ultimate disabled/uninstalled, then take up the extension owner. Our adblocker works better than this extension.

Same here actually even with all extensions I turned OFF, it is a black screen on any of the stream. One version before everything worked normal.

Does it work if you view it in a Private browsing window?

Private browsing work normal without extensions but when I tried with “Alternate Player for” in same mode still getting black screen, even if turned OFF in normal browsing maybe that extension bugging somehow the browser. I’ll try reset to default settings everything and delete cookies either. Defienietely something off with that new update because yesterday worked flawless.

No just only the ad blocker thing is messing it up rest extensions are fine

I’ll wait for update with fix then

@spe3tre @Easybadsxxxxxxx

If it was Brave itself, then it wouldn’t work in Private mode.

But all I know is TwitchAdSolutions pushed an update few hours ago, to fix the scriptlets they offer (which are hit and miss) because logged in users weren’t being able to watch streams/block (some) ads.

TwitchAdSolutions has two scriptlets and seems like both were having issues as well, so it was something Twitch changed that affected ‘adblocking’, it was happening to me, and updating the scriptlets fixed it.

The problem is when blocking the ad before the stream loads for logged in users, that’s what causing the issue, so only a third-party extension/adblocker is causing the issue like a most likely garbage adblocker like Adblocker Ultimate (at least use uBlock) or the Alternate Player extension.

My issue was caused because of having my scriptlets outdated in Brave and uBlock, so it wasn’t working properly, so you don’t know what those extensions are doing but they probably suffer the same issue scriptlets from TwicthAdSolutions were suffering before the update like 10 hours ago.

But Brave Team hasn’t updated lists regarding Twitch recently, Brave VANILLA doesn’t have those scriptlets included in their resources file by default, Brave Adblocker also hasn’t been updated in weeks which means no new features or anything in Yesterday’s update, so nothing should be a problem in Brave and people shouldn’t jump to conclusions and blame Brave for it.

In fact, I tested it in a new profile, without my custom rules, lists or scriptlets and even even without uBlock or anything else, just Brave Shields in Aggressive mode and Brave loaded the stream just fine, of course it showed the Xbox ad, but it loaded fine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.