Big troubles with Brave browser

It’s been a while since Brave can’t let me log in in uphold or use buttons in the browser, feels like i press the buttons but anything happens also the browser don’t show me captchas.

I tried to clean cache, history, reinstall the app deleting data and even install an 32 bits version (on 64bits windows 10 pc) but nothing works. Also tried delete all things of previous browsers including cookies and files but doesn’t work.

Can somebody explain me this? Please i have tried everything but brave don’t work, and i have this troubles in the last 2 or 3 versions

I’ve been seeing other reports of this behavior as well. Would you mind telling me what region you’re located in, as well as what browser version you’re currently running (Menu --> About Brave)

I’m currently on South America (LATAM) most especific on Argentina. (I have another pc with brave in 32 bits but doesn´t have this problems) and this is the version that dont work

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.