Beta not updating


#1

Brave Beta is not updating for me. It checks and says “up to date”. Checked and found nothing in firewall or antivirus that shows update is blocked. My current version is 59.14. Thank in advance, once again! :smile:


#2

@jaybird,
0.59.14 huh? That’s at least 2 releases behind.

What OS are you using? Additionally, when you go to About Brave (bottom option in main menu), does the browser attempt to update at all? Or does it just say “you’re up to date”?


#3

Windows 10 1809 64bit, with AVG Free & VoodooShield Pro as protection. About Brave _very briefly (~1 sec) checks for updates & results always the same. Beta is installed on a SUA.


#4

Hi, have you tried updating Brave via the actual installer?
If No:
Go to brave.com/download
Download
Execute =)

This serves as a replacement until the update function works properly.


#5

@MediaBird,

Yes, I tried this earlier and I got Brave Beta version 61.36. Updating this way is not an optimal situation, and I may simply uninstall it completely if it’s not resolved. :thinking:


#6

@jaybird, glad this worked for you.
There are a variety of potential causes for this but any time issues like this produce in the wild, they’re generally resolved in subsequent updates to the browser (or, in some cases, the OS). I believe some extensions have been known to conflict with the updater (among other things) as well - I’ll see if I can find some examples.

If you encounter this again, try disabling extensions before initiating the update process.


#7

@Mattches,
I use a couple of extensions. I’ll try disabling them individually when next updating. And 1809 is well known for causing all sorts of problems. Maybe the April feature update will bring some relief.


closed #8