Beta/Nightly (WebGL and Playcanvas) animation bug in Townstar

Evening Brave team \o.

I have come across a little problem in the Beta/Nightly builds.

Version 1.16.62 Chromium: 86.0.4240.80 (Official Build) beta (64-bit) and the previous build.

Version 1.17.32 Chromium: 86.0.4240.80 (Official Build) nightly (64-bit)

No extensions and clean installs, all shields down.

Brave official previous builds and latest work fine.

Version 1.15.72 Chromium: 86.0.4240.75 (Official Build) (64-bit)

The problem: Playcanvas and WebGL (possibly)

Although visiting https://get.webgl.org on Beta or Nightly yields a positive result, in a game called Townstar in a certain area on the map, it does not.

It should look like this

Instead it looks like this

The ponds water ripples are replaced with static blue blocks. And the Storage over to the right is replaced with a blue bubble. On the backside of that storage is a animated fan (PNG particle using Playcanvas) Also, the blue blocks above the wood sheds are supposed to be dynamic exclamation marks telling us the sheds full. So it seems to be only happening to these animations that are using PNG particles in Playcanvas.

Another working example in Brave Official.

And Beta/Nightly

The animation for the wood shed (right side) is not there at all (red swirls.)

The storage building (left side) should show a fan/cooling system with steam or smoke. Instead is replaced by a blue bubble.

I’ve contacted Townstar devs too.

Thanks
Zer0

@ZerosNOnes,
Looking into this issue right now – will get back to you when I’ve tested.

1 Like

It seems to be happening on land that terminates at the edge of oceans.

Thanks a bunch, Mattches!

1 Like

I have created a report, https://github.com/brave/brave-browser/issues/12167

2 Likes