Beta crashes accessing Sigma Aldrich site

For my job, I need regular access to Safety Data Sheets (SDS). My go to site is Sigma Aldrich (https://www.sigmaaldrich.com/united-states.html). The main Brave browser will only download the .pdf SDS files and open them in a separate .pdf reader.

I downloaded the Beta and the first site I went to was the Sigma Aldrich site. I entered a chemical into the search and the browser crashed. I thought it was something with the installation, so I tried it again and another crash.

Using another browser, I performed a search and the page loaded (https://www.sigmaaldrich.com/catalog/search?term=Calcium+chloride&interface=Product%20Name&N=0+&mode=mode%20matchpartialmax&lang=en&region=US&focus=productN=0%20220003048%20219853286%20219853269). I clicked on the SDS link for one of the entries, and I get an invalid .pdf error. I was about to get a screen shot with the Windows 10 Snip tool, but the browser crashed again.

@cynical13 Thanks for reporting the issue.

I could not reproduce on my end.
Steps:

  1. Go to https://www.sigmaaldrich.com/united-states.html
  2. search Calcium chloride
  3. Click on a search result
  4. Open data sheet in pdf

I used build from: https://brave.com/download-beta/

Brave 0.55.10 Chromium: 70.0.3538.22 (Official Build) beta (64-bit)
Revision ac9418ba9c3bd7f6baaffa0b055dfe147e0f8364-refs/branch-heads/3538@{#468}
OS Windows 7

@cynical13 Could you include brave version and check if above steps reproduce for you?

@cynical13 There is also a known issue with Brave rewards randomly crashing the browser.
Try turning Brave Rewards off if you have them enabled.

I did in fact have that option turned on. I’ll have to experiment more to see if it fixes the random crashing.

I did get the product information sheet .pdf to come up, as you did. However, the SDS is still not coming up because it is embedded in the page in a panel (I’m not completely up on terminology).

An error window comes up saying “Invalid or corrupted PDF file”. If I click on more information, it says “PDF.js v2.0.673 (build: 31012570)
Message: Invalid PDF structure”

@cynical13 Good news. I was able to reproduce the issue.

You can check the status of the issue:

1 Like

Woohoo! It’s verifiable broken!

In all seriousness, thanks for looking into this. Once this is fixed, I’ll be spending a lot more time in Brave.

@cynical13
I also get the same error message for pdf opened from pubs.acs.org pages.
Thanks

1 Like