Being forced to update on incompatible OS

ScreenShot

You recently dropped support for my OS (Mac OS 10.14 Mojave), and I clicked on your agreement that I understand the security risks of not being able to update. This has been fine until today, when I keep getting the annoying message above (see attached screenshot). Please fix this!