BAT rewards settings page doesn't load

I have installed BAT in Windows 10. I get ads and reward amount increases in the estimated rewards section. But rewards settings page doesn’t load. It is just a blank page.

Hi @saniro, there was an earlier post with this similar issue…

…you can have a read through it and see if any of the troubleshoots might help you while you wait for @tmancey, @Mattches, or another staff member to respond.

1 Like

That previous thread was closed automatically due to inactivity – I’ve reopened it as the issue seems to be around still.
Can you please right-click on the Rewards page and click Inspect, then in the dev tools window that appears, go to the Console tab and send me a screenshot of the output (example below)?


1 Like

@Mattches Today I received BAT rewards for last month. Even though I have accumulated over 5 BAT for that period I only received 0.435 BAT. I think this has something to do with brave rewards page not loading issue. Please help me to resolve this.

We’ve identified the issue and have released a fix that should be pushed into stable build soon:

1 Like

Thank you very much. @Mattches @saereV


Still having the same problem after 1 month and I have updated to the latest version. What should I do ?

Hi @saadbitar98, I’m sorry to hear that. :frowning:
@Mattches would be able to better help you with this, as it’s build-related.

Can you please tell me what OS your’e using, what Brave version you are using, whether or not you have any extensions installed, and a screen shot of what you see in the dev tools console window (follow steps from my previous reply)?

I’m using windows 10

Version 1.23.75 Chromium: 90.0.4430.93 (Official Build) (64-bit)

and here are my extensions

First, please update to the latest build of the browser by going to Menu --> About Brave. Latest build is v1.24.82 at the time of writing this. Then, can you please try disabling your extensions temporarily and then test again and see if the Rewards settings page appears (probably safe to leave the Crypto Wallets extension enabled since it’s built-in and very unlikely to cause this kind of conflict)?

did all of that, but still the same

I did all of that but I’m still having the same problem

Thank you for testing. I believe that you were running into a known issue that has already received a fix. The fix should be in the next browser update:

Still not fixed. Relaunched, updated and extensions disabled.

Version 1.24.85 Chromium: 90.0.4430.212 (Official Build) (x86_64)

1 Like

It appears that his fix is scheduled for the 1.25x release – the latest was 1.24.85. Let me ping some of the team and see if we can get an uplift for this particular issue. Just know that the fix may need to ride the trains all the way until the 1.25 release.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.