BAT Ledger CPU usage at 100% - publishers no longer recognized, outdated rewards info

I upgraded to 1.4.96 (I don’t know which version I was running before) on Windows. Using the 32 bit version. All of a sudden it doesn’t recognize registered publishers any more (e.g. Duck Duck Go). The check icon doesn’t show, and if click the triangle it no longer has any Tipping controls. it just shows my funds and March summary.

EDIT: Just saw that Brave’s BAT ledger service keeps the CPU at 100%: https://i.gyazo.com/27da20b2b1ce14ee278791bfe00d2906.png

Process Hacker says the function causing it is GetHandleVerifier in `brave.exe!GetHandleVerifier+0x961e0

I tried disabling all extensions. Nothing changed. If I try to kill the “Bat Ledger Service” from Brave’s task manager, it just comes right back and instantly at 100% CPU again.

Also, if I go to “reward settings” it shows the wrong amount of my balance (orders of magnitude wrong). It also says “Next payment date: Mar 5” … which is in the past (date of this post is Mar 8). Also, clicking on “7-day Ads history” shows an empty table (whereas I had loads of them in the past week).

I installed v1.3.118 from github (and verified I’m running 1.3.118 in About) … it does the same thing.

Something’s off. Seems like server side? Can someone confirm?

Anyone?

[20 characters]

1 Like

I am experiencing the same issues (100% CPU usage by BAT Ledger Service, lack of check icon for registered publishers) with Brave 1.4.96 on Ubuntu 18.04.4 LTS.

2 Likes

@alexr @boop_boop,
Apologies for the inconvenience.
Regarding the missing BAT – many users are seeing similar behavior that the team is aware of and already has a fix being worked in to resolve the issue (all funds are still there).

Regarding Ledger service – This had been an issue a while back but I was under the impression that it had been resolved. Let me reach out to the Rewards team for more info – thank you for your patience.

2 Likes

Same experience with Version 1.4.96 Chromium: 80.0.3987.132 (Official Build) (64-bit) on Ubuntu 19.10.

100% CPU on BAT Ledger Service. Does not help to turn off rewards. I need to stop using Brave, CPU fan is going constantly.

2 Likes

@magne @boop_boop @alexr,
After discussing with Rewards team, it looks like we have a fix for this already in Nightly builds and getting uplifted into Beta as we speak so we should likely see this issue resolved very soon.


We appreciate everyone’s reporting and patience.

1 Like

Interesting to hear this is experienced in 1.4… 1.4 doesn’t contain the bug we just fixed. So I think there is another issue present with similar symptoms

We’ll continue looking into this

2 Likes

Do you mean a fix for both issues (1) 100% CPU and (2) broken rewards integration (no longer recognizing registered publishers, wrong balance, missing TIP option, etc) ?

I also note that I haven’t been receiving any ads either since this started …

Ok, I just installed 1.7.61 Beta (from Github, posted 6h ago) then copied by Default folder profile from Brave-Browser\User Data into Brave-Browser\User Data so I can test my profile … CPU usage of the BAT ledger is now normal, and registered publishers are recognized.

Is it safe to copy the “Default” folder between Release and Beta versions?

1 Like

@alexr – I would be careful when doing so. I believe it’s fairly safe to do if the data is moving from newest (least stable/Nightly) --> Oldest (most stable)

Hmm … I would have thought it’s safer to go from stable to beta/dev/nightly (because later releases could recognize older profile data, whil adding new features) … but less safe the other way around (older releases possibly not being able to deal with profiles created with newer versions).

@alexr,
That is actually what I had intended to say – thank you for catching that.

I can confirm that the new stable version 1.5.115 still has this bug exactly as described in the 1st post for v1.4 (100% CPU for BAT ledger service, wallet not working, publishers not recognized).

Perhaps there should be less of a rush to push out new stable versions? These are pretty big bugs for two consecutive major stable versions (1.4 and 1.5). Makes Brave look unreliable.

Windows 10 Pro build 1909, i5-6500T, 16 GB RAM.

EDIT: For anyone here who insists on using Brave in this state then you can suspend the ledger sub-process. I used Process Hacker, right click the Brave.exe sub-process that has high CPU usage, choose “Suspend”.

I can confirm that the new stable version 1.5.115 stillhas this bug on Mac :'c

Brave updated to 1.5.115, but BAT ledger service is still using 100% CPU on my Ubuntu system.

The team is working on it. Thanks for your patience.