Bandcamp - when streaming the tab often shows "aw snap" error. How to fix?


Description of the issue:
How can this issue be reproduced?

  1. open a tab on any bandcamp artist (e.g. https://hugokant.bandcamp.com/album/beyond-the-tracks)
  2. start streaming
  3. leave the tab and do other things in the browser (or even leave it as it is)
  4. after a random amount of time, the audio stream will stop and the page will show the “aw snap” error message
  5. in another situation, it seems to be triggered by accessing the bandcamp streaming tab after having left it for some (random) time.

Expected result:
The tab will crash.

Brave Version( check About Brave):
126.0.6478.71

Additional Information:
It happens with and without “shields up”.

Nobody has similar issue? Or at least some hints on how to debug/correct it?

I also got this issue, but mostly it crashes when i got bandcamp opened, searching through other tabs and then, when i click on the bandcamp tab with music runnning, it crashes.
Same and more often on NTS Radio.
I think it has sth to do with the media player, because both sides are crashing while playing music…

OK, so I’m not alone in this. Anything we can do/check to fix this issue? Or isn’t it at all Brave-related?

@FlavioB and @aeroen I assume it’s related to Spotify keeps crashing in Brave

Which seems to more or less be an issue with the player/website. You can see a bit of a reference to that on reply below where links are shared to various reports:

That said, I also want to ask, what are your settings at brave://settings/system? More particularly, asking about Continue running background apps when Brave is closed and Memory Saver?

Thanks for your reply.
I’ve verified the settings you were asking about:
Memory Saver is on, but I can’t find the other parameter. Can you show me where to find it? I’m running Brave 1.67.123
Thanks.

Has it always been on? If so, turn it off and see if there’s any difference. With it on, it’s going to take priority away from tabs you aren’t using. So as you switch tabs and are reading other things, the browser could end up seeing it as inactive and go to suspend it, which then results in it showing something went wrong

This is just a wild guess and just something I’m checking in with you to find out, as it’s a simple enough thing to verify (or test).

It’s in Settings → System, or can type in brave://settings/system as I mentioned earlier.

It’s on the top.
image

Realistically that one about running background apps when closed shouldn’t really have an impact, but sometimes oddball things happen. So figured I’d just try to verify.

The two things I’ve mentioned is just all about trying to keep Brave active and not having anything end tabs or processes.

Thanks again for getting back to me.
I don’t have the “Continue running background apps when Brave is closed” setting:


What I was thinking about is to add the bandcamp URL to the list of sites “Always keep these sites active” - maybe that’s similar to disabling “Memory Saver”, but just for one (or more) specific sites?!