Bad suggestions on omnibar

My most accessed website is Telegram.
I never, not even once, went to The Telegraph website by typing its URL. Why is it the first suggestion every time I type tele?

This is just an example but this seems to be the default behavior. Why is that? And can I turn off random suggestions in favor of suggestions from my history?

es lo mejor para el uso diario de informacion ei entretenimiento ayuda en una busqueda clara y sin restripciones para im diaro


@felds Open brave://settings/appearance and check if "Show top sites in autocomplete suggestions" is enabled as in image below.

Thanks for the help, my friend!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.