Bad colour rendering of FavIcons

I have noticed over the last week or so the rendering of fav icons in tabs is off. A picture is worth a thousand words so please see the attached. The top row is Brave Version 1.47.171 Chromium: 109.0.5414.87 (Official Build) (64-bit). The bottom is Vivaldi 5.6. The difference in the rendering is obvious.
System: Debian 11 w/ Cinnamon.

3 Likes

I have the same problem since two weeks ago or so.

Any solution?

1 Like

I have the same or a similar problem… since about 2 weeks Icons appear strange in top bar and also in bookmarks tab. I was getting paranoid if there is some kind of malware “overlaying?” on top watching my transactions…
See the strange color rendering in the icons:
image
image

Any solution? It’s really annoying seeing this weird icons.

I’ve also been experiencing this rendering glitch for the past week or two.

When the favicon first loads it renders fine, but as I leave the page open for longer, the icon continues to look more “corrupted”.

It also affects the Brave Shields icon:

image

However, it doesn’t seem to affect certain favicons at all. For whatever reason, the favicons for Google, Google Drive, and Gmail are not affected. Perhaps it’s an issue with rendering a particular file type used for some but not all favicons?

Running Windows 10 (64-bit), Brave version 1.47.186 Chromium: 109.0.5414.119 (Official Build) (64-bit)

In my case, the “corrupted” icons are Google Drive, Gmail, Google Photos, YouTube, all the folders and Brave Shields icon.

Also having this issue on Pop_OS, with Nvidia GPU. For me its Youtube, Gitlab, Reddit, Email.cz Brave lion both next to the address bar and ICO, Gdrive in the yellow section. Its weird how it affects red/orange icons but any other color seems to be OK.

Same problem here since some weeks.
I’ve Linux and nvidia GPU, although it’s not used for I use the integrated Intel with Mesa without activating nouveau.
I’ve the same corrupted icons (Youtube, Gphoto, Brave lion, Gdrive etc) as mentioned.

Maybe it’s a coincidence, but it seems to affect favicons with predominantly red/orange/yellow color.

Examples of corrupted icons:

  • wp(dot)pl
  • gazeta(dot)pl
  • reddit(dot)com
  • stackoverflow(dot)com
  • netflix(dot)com
  • youtube(dot)com
  • mcdonalds(dot)com
  • onet(dot)pl
  • vectra(dot)pl

Examples of NOT corrupted icons:

  • facebook(dot)com
  • upwork(dot)com
  • hbomax(dot)com
  • duolingo(dot)com
  • whatsapp(dot)com
  • benq(dot)eu
  • milka(dot)com

In private mode the icons are shown correctly.

I have the same problem with Version 1.47.186 Chromium: 109.0.5414.119 (Build officiel) (64 bits).

Just checked and you are correct.