Back and forward swipe gestures in Linux?

I’m using Gnome on Fedora 38 and the swipe gestures on the trackpad for forward and backward don’t work, as they do on MacOS. Is there a way to turn them on or is this not a feature yet for Linux?

I don’t know why this isn’t enabled by default, but you can get the swipe gestures to work by starting Brave like this:

brave-browser --enable-features=TouchpadOverscrollHistoryNavigation

Also make sure to use a Wayland DE and set “Preferred Ozone platform” in about:flags to Wayland.

this does not work for me. I’m on gnome fedora 39 and brave was installed from the store software. Any ideas?

I am on KDE Plasma Fedora 39, but this will probably still help. You likely have this file:

 ${HOME}/.local/share/applications/brave-browser.desktop

Add the flag stated from before to the execution command under this specific section (don’t add a new one, edit the existing Exec command):

[Desktop Entry]
Exec=/usr/bin/brave-browser-stable --enable-features=TouchpadOverscrollHistoryNavigation
1 Like