Today I fired up the lappy clicked Brave to see “Aw Snap STATUS_INVALID_IMAGE_HASH”

Great so I Googled and tried a few ideas from here

and here and later
and here
none of these worked for me but others did have mixed success.

Why did it happen
I have no idea what happened from the time I closed down my laptop last night to this morning, maybe an update occurred to windows 10 or Brave?
So I cannot reproduce this issue or say why it has happened.

What did I do to fix it
Disabling Avast Secure Extension in Brave only later to uninstall it completely, didnt work
Changing flags in the Properties /Target line of the desktop icon, didnt work
Creating registry keys and adding flag to the same Target line above, didnt work
Uninstalling rebooting then Reinstalling latest versions a couple of times, still didnt work
Thought Beta version would fix my problem but still did nothing
Running in Compatibility Mode was the only thing that worked but with issues

So running in compatibility mode was my one thing that worked, crap :roll_eyes:

Expected result:
Nothing I did would fix this strange issue that just appeared out of nowhere I resigned myself to being stuck in compatibility mode forever as my only work around, what a pain

Brave Version
Latest V1.32.115

Additional Information:
There was one place that I visited which held the answer and I didnt even realise it till an hour or more ago when I re-read it…

The point I missed in this article was name changing the exe file. It was by far the easiest and quickest of the fixes I could have saved several hours by just doing this one thing today.
As I couldn’t find anything on this community I thought maybe I should put this up for others

So the fix
A simple name change to the Brave.exe file (I did IMBrave.exe) and that fixed my issues, you can find it at
C:\Program Files\BraveSoftware\Brave-Browser-Beta\Application
Right click on Brave.exe select Rename from the list, change name to something else I did IMBrave.exe and save it.
Then delete the desktop short and create a new desktop shortcut from the newly named file IMBrave.exe and voila its up and running again with correct icon, just like before. Phewww

Hope this helps someone else out. Cheers

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.