AW Snap errors after window 10 upgrade Desktop

Hello,
I initially installed Brave on my PC, and was not able to use, getting “AW Snap” errors on all of the pages. Then I saw an article to rename the brave.exe to ibrave.exe and that worked with no issues.
Windows went through an update and now ibrave.exe is opening, and I see my bookmarks, but I can not open any of them, the browser screen just stays blank and it times out. I tried reinstalling but that did not help.
Here are my PC characteristics:

Edition Windows 10 Pro
Version 21H2
Installed on ‎6/‎4/‎2021
OS build 19044.1766
Experience Windows Feature Experience Pack 120.2212.4180.0

I was enjoying your browser but I need something more reliable at this point in time, so any direction would be appreciated.

Thanks,
frank

additional information; update history:

June 14, 2022—KB5014699 (OS Builds 19042.1766, 19043.1766, and 19044.1766)

also tried opening up a private window but that did not work either…

Really impressed with all the responses and suggestions!!! Thanks for all of the valuable information.

@Jure Well, I know very little about this but will attempt to help. Basically, just reposting information from the Help Center and other topics. Hope it does help.

If it doesn’t, you should update what you have tried and the results and then you should tag the moderators in the update to see if they can provide additional help and troubleshooting.

  1. I have never heard of renaming the .exe from brave to ibrave. I suggest you reinstall brave browser from the installer and not rename anything. Your data files should be ok but just in case, you should backup your Brave-Browser folder. You can restore from the back up if you do lose your rewards and/or other information. The current Brave Release version is 1.40.109. Verify Brave did update to the latest version.

  2. Create a new test profile and see if the problems persist. If you can, export your bookmarks from the default profile and import them into the test profile and see if they work. If you can’t export, you might try just copying over the default profile bookmark file over, but I really don’t know if that will work or not.

  3. If you have any extensions installed, disable them, clear history/cache for all time, exit and reload browser. Might want to try a computer restart too.

  4. Try installing Brave Beta and/or Nightly and see if the problem occurs in those versions.

  5. Help Center article on Aw Snap errors below. If you get the error again, use this article to troubleshoot.

Post an update on what you tried with results (even if no impact). Tag a moderator in the update if still having problems.

2 Likes

Thank you for your response. I will try some of the suggestions later this weekend, too nice to be inside working on the computer. Just as a reference, I did make a mistake, the article that I was referring too on the Brave support with respect yo renaming the .exe to imbrave, no ibrave as I indicated. Here is the link to that article.
Aw Snap STATUS_INVALID_IMAGE_HASH - Browser Support / Desktop Support - Brave Community
Thanks again, I will share my results probably sometime next week.

Wish I could say the same. Has been overcast and raining here for the last two days. We needed the rain, water table down 11 inches from normal, but definitely no going outside for me. lol

Just want to confirm STATUS_INVALID_IMAGE_HASH is the error you are getting. I should have asked before but didn’t think. Ooops. Try the following in addition to the things already listed.

  1. Disable hardware acceleration at brave://settings/system
  2. Disable any anti-virus software.
  3. Exit browser. Right click on the Brave icon and select Troubleshoot compatibility .

Again, please post an update. These are just basic troubleshooting steps.There are other things out there to try but if nothing works with the basics, I think tagging a moderator for professional support help would be your best next step! :smiley:

1 Like

So I had some time and here are the results of the suggestions:

  • could not bring up the brave://settings/system page, a blank page appears
  • could not bring up the “new profile” window, a blank black window appears, but no text in the new window.
  • When right clicking on the icon, I do not have a Troubleshoot compatibility option.
  • with anti virus disabled, all the results are the same as stated above.

The message that I am receiving is:
Error code: STATUS_INVALID_IMAGE_HASH

When I click on “Learn more”, a new window pop’s up but once again the window is blank

Thank you again for your suggestions.

I also did:
reinstall - no difference
beta install - no difference

Thanks again

Sorry for delay. I took a break.

I found a topic that had a similar error issue. Posting at the end below. It has links to two external articles and I am also posting two more. And guess what, renaming .exe is a workaround in the articles! I definitely wouldn’t have thought that.

I did a search on other topics in the Community and the most common fix in those topics appears to be right clicking the Brave icon, opening Properties, and inserting
–disable-features=RendererCodeIntegrity at the end of the string in the Target field. This is a post with a screenshot: Aw, Snap! Something went wrong - #37 by pradhyu89

If you can get to brave://crashes, can you check to see if there are any crash reports there? If inserting the flag at the end of the .exe target doesn’t work, it is probably way past time to call in the big guns, aka Brave support staff, to help. Just tag them in your next update if you are still having problems.

Links:

1 Like

Thanks for the response… Away from my PC which has the issue for the next 2 weeks, will try your suggestions once I get back home.
Still raining? Was the 11" deficit recouped yet?

Not raining continuously as it was. Just having scattered thundershowers now which don’t last long. Have only had 5inches of rain for the month, so going to have to rain a lot more than that to catch up. :slightly_smiling_face: