Autoplay was blocked on this page pops out all the time

I’ve been using Brave for about a week now and since this morning I see this little (horizontal) popout in my address bar that tells me ‘autoplay was blocked on this page’. I get this on twitter every single time I click something and it’s really, really annoying. I clicked on the little icon and it brought me to a settings page. Autoplay is always blocked, so I don’t need Brave to tell me this all the time. Can I disable it somehow? I also added Twitter in the block list, but it doesn’t change a thing.

6 Likes

There is currently no way to disable these notifications. Honestly, it may not be a great idea to do so.

Without these notifications, you may encounter a website that appears to be broken in Brave, but in reality may just have a required element blocked on the page. The autoplay icon appears on Twitter so frequently because there are so many tweets with video and Gif content on any given page. It’s also worth noting that in addition to video streaming, Brave will notify you when an ad with video or sound attempts to play on the page and gets blocked.

Thanks for your answer.
This makes Brave unusable to me. I will not accept continously moving elements in my browser that distract me from what I’m trying to focus on. That’s why I use ad blockers.
I don’t need to be notified whenever something’s blocked. That would be an endless stream of notifications.

3 Likes

I’ve been using Brave off and on in muiltiple platforms since shortly after it became available and love the way it’s developed. It’s a wonderful product, and I very much appreciate the work that’s gone into it. So thank you!

I also understand that it’s important to have a way to know when autoplay has been blocked, as with many of the other features Brave offers, but I think that simply having the icon that’s there after the notification slides in and out is adequate notification that the blocking has occurred. Hence, I would very much like a way to turn off the sliding notification. On pages that have multiple autoplay blocks, which is far more than just Twitter, it becomes an extreme irritant. I’m far from the point that the OP has reached with wanting to abandon Brave over this, but @forlane has a point in that the visual distraction of the animation is akin to many of the ads we downloaded Brave to avoid in the first place. After all, we don’t get a sliding notification for every item Brave blocks in the name of privacy, and it would be crazy if we did; we downloaded Brave knowing it’s supposed to do that and are aware that blocking web page elements, including autoplay video/animated GIFs, can break pages. Thus, having the option to only display the icon without the sliding animated notification seems like a good compromise in that we have a visual reminder in the address bar if something breaks, but don’t have the constant sliding in and out of the notification when scrolling, say, a newspaper website.

Again, thanks for all the hard work in producing Brave as a great privacy tool, and I hope this compromise suggestion is met favorably.

2 Likes

We are currently working on different ways to handle these types of notifications - namely, we’re looking into adding both the settings and display for “blocked” notifications like this to the Shields panel.

Apologies for the inconvenience in the interim.

3 Likes

Excellent news, and thank you for the prompt reply, as well as for the hard work in developing this software. In my view, no apologies are necessary, and I hope you and all of the developers keep up their enthusiasm for the project.

2 Likes

Yes, this is incredibly annoying. I see it most often on news sites where there you usually find autoplaying videos (for example, The Daily Mail). I don’t mind seeing it once per session, but it pops out every few seconds. This forces me to switch to another browser like Chrome, when I would prefer to keep using Brave. Please fix.

5 Likes

+1

The slide-out / slide-in effect is the deal-breaker. As @macgregor just said, “once per session” would be acceptable as a reminder, but no more. And, my preference would be a setting to pick “once per session”, “every time”, or “never” animate. As other posters have commented, the slide-in / slide-out animation is as jarring and becomes as annoying as the auto-play video(s) that it’s suppressing.

3 Likes

I just started using Brave and I have to say this is making it very unattractive to me. It’s so distracting…my eyes fly up every time it pops out, thinking its an e-mail notification. It’s constant on certain sites. I’m going to have to switch back to Chrome until I hear this has been fixed.

1 Like

+1 more. I just switched today and it’s one of the first things I noticed. I read a lot of the “Gizmodo” family of blogs, like Kotaku and Deadspin, and while I enjoy their content, they’re notorious for autoplay videos so ad-blocking is essential. The slide-out “Auto-play was blocked” goes off constantly and might single-handedly kill my transition from Chrome. Please, consider another option, like hiding it under the Shield panel. Thank you!

I get this notification a lot on both Windows and Linux builds. On some pages it flashes for every click I make on that page, even if there isn’t any videos. And if I set it to always allow on that page it still continues to flash.

If you’re (all) unaware, we do have an open issue for this on Github that you can see here:


If you have an account, you may want to go in and +1 the initial post in the thread to get devs attention.

Gotta get rid of this thing. It’s driving me crazy.

+1

Loving the browser but this is driving me crazy. It was cool the first 10 times I saw it. Annoying after the first 100. Wanting to gouge my eyes out after the 1,000th time.

1 Like

I switched to dark mode with a dark theme and it lessens the impact a lot, at least for me. Here’s a list of the things I’m using to get there with Brave Dev 0.64.36 Chromium: 73.0.3683.75 (Official Build) dev (64-bit)) on MacOS 10.14.3 or .4, using Mojave’s native Dark Mode):

And in Brave settings:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.