Autoplay TOO 'strong'

PLEASE SEE https://github.com/brave/brave-browser/issues/18369 for original. Is anyone managing these issues on Git at all??

This issue is highly annoying - can I please block Autoplay, overall, without Brave then blocking TOO much media content (i.e. without Brave ignoring my / user input)?

COPY of GH details as of today 3 November 2021 (links ‘cleaned’ though - only 4 allowed here…):

(Please note: not tested on Android)
Please note issues that are / seem to / might be related, at the bottom under ‘Misc’.

PLEASE USE THE TEMPLATE BELOW TO PROVIDE INFORMATION ABOUT THE ISSUE.
INSUFFICIENT INFO WILL GET THE ISSUE CLOSED. IT WILL ONLY BE REOPENED AFTER SUFFICIENT INFO IS PROVIDED–>

Description

With Autoplay set to ‘blocked’, many (yet not all) sites are

  1. not even playing any media (audio/video) based on user input, at least not properly, i.e. when the user clicks ‘Play’, it is simply ignored (or cancelled).
  2. also blocked from ‘go to next file’, in playlists.

Steps to Reproduce

EDIT: added telling example on radiorecord( .ru).

  1. Ignoring user input:
    A. Go to an affected site (YT for example is NOT affected by this), for example radio, or vimeo. Twitch is another funky example, as is radiorecord .
    B. Click ‘Play’. In the case of radiorecord , click another genre while another one is still playing.
    C. ISSUE: the content does not play (not at all i.e. is fully unresponsive or loads indefinitely, or might not play until user clicks pause and then play once again; either way, content is somehow ‘overblocked’ or at least not ‘cleverly blocked’). On Twitch, the sound gets disabled and re-engaging it stops video playback. On radiorecord , the second genre refuses to play (unless the first one is PAUSED!!); the intitial genre does not trigger the Autoplay ‘Blocked’ setting, at all, but the switch to another genre does trigger it, and incorrectly ignores user input (‘Play’).
  2. Playlists
    A. Go to (an affected?) site with playlists, e.g. a Youtube or bandcamp (com).
    B. Open a Playlist (site with multiple ‘pre-loaded’ pieces of content ordered for continuous playback).
    C. Click Play.
    D. ISSUE: insofar part 1 of this issue is not triggered, the file plays, but the next one does not. Having to click Play for every part of a playlist defeats its purpose!

Actual result:

All scenarios: (immediate) playback is blocked (see ‘ISSUE’ under repro steps for details).

Expected result:

  1. Playback should work
  2. ‘Automatic’ playback in playlist should potentially be allowed (probably more a feature request than a bug - maybe split?)

Reproduces how often:

100% - depending on specific site content playback technologies, and how the Brave protocols (do not) handle these, exactly.

Brave version

Version 1.29.81 Chromium: 93.0.4577.82 (Official Build) (64-bit)
Win10 Home 19042.1237

Version/Channel Information:

Other Additional Information:

No issue with Autoplay off.
Shields do not seem to make a (bug) difference.

Chome repro TBD

Miscellaneous Information:

A few (potentially / somewhat) related issues, maybe this helps. Any linkage we could/should do?
(see GH - cannot post more than 4 links here -.-)

Hi @Fallenknight welcome to Community.

Can you confirm if you are on the latest version of Brave.
I tried to replicate your steps and had no issue, have you toggling some shield settings to see if that might be affecting the playback.

I am, yes. This (sort of thing, around Autoplay) has been an issue since 2020. The Autoplay (blockage) is not working optimal at all. I seriously LOVE how aggressive it blocks, but bottom line: if USER CLICKS ‘Play’, then that is not ‘Autoplay’!

Shields UP everywhere, yes, but I merely use the STANDARD / DEFAULT setting, and that should not break anything, of course.

Try this particular set of steps, this has to be 100% repro across all browsers (else: why would mine act so deviantly?):

  1. Verify settings ‘Autoplay = BLOCKED’

  2. Go to radiorecord.ru/stations

  3. Click any station/channel/genre - it will play immediately (as opposed to a lot of other media content on the web).
    A. Verify, for same channel: click Pause (music stops), click Play (starts).
    B. Verify other channel. IMPORTANT, FIRST: click Pause again, on channel under ‘A’. Then click another channel. No problem (other music starts).

(NOTE - no ‘Autoplay blocked’ icon can be seen in the address bar; confirmed no issue, upto this point)

  1. While the music is playing, click another channel. Observe the ‘Autoplay blocked’ has now been triggered, and the music refuses to play. The only options are ‘allow Autoplay’, or reload the site.

Again, this is BY FAR not the only example, and I cannot for the life of me imagine that I am the only one experiecing (at least something like) this!! Really looking forward to input from you again / multiple others.

Thanks all.

Even without the autoplay disabled, it doesn’t autoplay until you select a station on radiorecord.ru/stations which should be a good thing tbh. Compared with Chrome, we’re doing the same thing here also.

Maybe just actually follow ALL the steps as outlined. No offense, but this comment is just lazy, tbh…