Autoplay media popup

I like the autoplay allow or block feature. On a lot of other browsers ive used in the past, it has been useless and ineffective. When I block autoplay in Brave it is solving some very annoying issues on a few websites I use. For example, those irritating autoplay videos that minimize and follow you down the page. Considering how useful it is, and I dont clear site settings so it isnt recurring, I dont mind the popups personally. One click and sorted.

A little buggy though. Whether I block or allow youtube, videos pause when the curser is moved over the info bar. I use Freetube quite a lot though, so not a huge deal. I have wondered whether this is an adblock / google trying new things situation, maybe it is, and I dont know. Occasionally autoplay ad videos will get through the block, but is it quite rare.

Installing AutoplayStopper stopped videos autoplaying for me and for others. YMMV.

Search Brave Community. Autoplay is discussed in this thread (amongt others) including mention (Krebs on Security and Ars Technica) of some perils in installing and relying on extensions.

I’m not worried much at this time about auto play. I’m trying to stop the autoplay popup on EVERY website I go to. Even those that contain NO videos. Wish someone from the Brave team looks at this post!

1 Like

I think I understand the distinction you’re making between a pop-up asking about playing video and autoplay. My experience: installing the AutoplayStopper extension eliminates both. Try it. I you don’t like it, uninstall it.

Will wait here too. Extremely annoying behavior. AutoplayStopper does not eliminate popup for me unfortunately.

AutoplayStopper does not eliminate popup for me either. Brave says to post something in this forum to report a bug, but no one with Brave has weighed in on this. Sad support!

Could you guys post a URL so I can check if I have the same problem?

It’s not a bug its asking permission to autoplay, I’d think that’s an expected action.

tagging the Brave Support team: @Aa-ron @steeven

If you go to a website with NOTHING but text and you get an autoplay pop up, I’d consider that a bug.

What sites do you see it on?

Here’s one:

Possible resolution:


or (this is the same thing)

Settings | Additional Settings | Privacy and security | Site and Shield settings | Additional permissions | Content | Pop-ups and re-directs | Blocked (recommended) … Block Allow specific sites

In addition to generally blocking pop-ups, try entering the url’s of specific offending sites in the “Block” list

Some details: within Brave’s settings, I do have pop-ups blocked and I have no specific sites entered. Extremely rarely I do see pop-ups. (This infrequency is one reason it’s taken me a while to get back to this thread.) For me, these have been welcomed alerts so it took me a while to connect this rare behavior to the complaints mentioned in this thread. Because for me this behavior is both rare and helpful, I’ve not considered entering specific sites in the “Block” list. Indeed, my lists (both Block and Allow) are unpopulated. You might try entering offending url’s in your Block list.

Worth adding: I haven’t a clue why, if Pop-ups are generally blocked, certain pop-ups continue to “leak” through, but actually, those I receive are helpful.

Also worth adding: consistent with the earlier links about risks associated with extensions, if you’ve installed AutoplayStopper but you don’t find it helpful, it’s probably prudent to remove it.

Also also worth adding: specific to your Sad support! remark, my copy of Brave was free. I assume yours was too. Speaking only for myself, I think I’m getting full value for what I paid.

I don’t get any popups or autoplaying media; just the webpage. I don’t use any extensions. (Brave 1.18.77, Windows 10)

I could be wrong, but I think op is referring to the autoplay notification (block allow) popup, not ad popups.

This is what I’m getting on many websites with no media at all. I can’t explain why others try it and don’t get this annoyance, but I assure you that I AM getting it!


I don’t get any notifications (Brave 1.18.77, Windows 10)

I have the same bug. You’ll see the notification when you open this page.

If you allow autoplay, the notification won’t be shown again.

Like tanker, I am also having this issue. My autoplay is set to Allowed but I keep getting the the autoplay banner on every page.

Edit: Looks like creating a new Brave profile seems to fix the problem

1 Like

Does this mean we all have a bad profile?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.