Autofill NOT Working

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting

Description of the issue: The Autofill feature is not working, it does not Autofill AT ALL any fields in the months I have been using Brave. I am finally sick and tired of manually inputting my details all the time for everything so I finally signed up and am seeking help with this matter.
How can this issue be reproduced?

  1. I am always asked and I always say Yes to save passwords, payment methods, Addresses.
  2. However, saving this info doesn’t seem to do anything as the next time I go to login or enter my payment info, I will have to enter it manually.

Expected result: Make Autofill actually work by autofilling all the passwords, payment methods, and Addresses I have saved.

Brave Version( check About Brave):
Version 1.20.110 Chromium: 88.0.4324.192 (Official Build) (x86_64)


Additional Information:

To start, can you please update to the most recent version of the browser? Go to Menu --> About Brave to initiate the update, then let me know if the issue persists.

Done! I figured you would ask me that! After updating, I went to the login page of my email, manually logged in since it didn’t autofill my info, then saved the username & password again, logged out, then opened a new login window only to see Autofilll still not working. I tried a couple other sites and it doesn’t work AT ALL!

Brave is up to date

[Version 1.21.77 Chromium: 89.0.4389.90 (Official Build) (x86_64)]

Can you please go to Settings --> History --> Clear browsing data and ensure that you do not have the Autofill and form data option selected in the On Exit tab? Can you also tell me if you have any extensions installed at this time?

@Mattches Thanks for the quick reply!

The Autofill and form data option is not checked on the On Exit tab.

I haven’t added any extensions, but looking at the Settings > Extensions looks like the following is enabled by default:
Private window with TOR
Web Torrent

Nice to see Brave uses Discourse as we also use it for our site!

1 Like

Thank you for confirming.
Not sure what the issue would be then. Do your login credentials actually get saved to brave://settings/passwords or is that data getting erased as well?

So upon checking the passwords page, it’s actually not showing any Saved Passwords surprisingly since I have been saving the passwords for months now. So this is likely why it’s not working.

As for brave://settings/payments, I noticed the following setting which is disabled, does this need to be enabled for Saved Payment methods to Autofill?
“Allow sites to check if you have payment methods saved”
I would imagine the 1st setting to “Save & Fill Payment Methods” would work!

Upon testing, it looks like Saved Addresses are working!

1 Like

Glad to hear it is working, I figured it had something to do with the passwords not saving. However, I’m unclear on whether or not those passwords are saving now ? Additionally, did you have to enable the Allow sites to check if you have payment methods saved option or were you just asking about it?

Only the Saved Address are working to Autofill.

The Saved Passwords & payment methods are not working to Autofill.
I still have to manually enter those every time.

I was just asking the following and did not enable it: (it seems it Autofill payment should work without the following setting)
I noticed the following setting which is disabled, does this need to be enabled for Saved Payment methods to Autofill?
“Allow sites to check if you have payment methods saved”

No, you should not need to enable Allow sites to check if you have payment methods saved in order for payment information to autofill.

As for your passwords and data getting Autofilled, I believe you need to (re)grant Brave permission to access your keychain/safe storage. Please try the following:

  1. Open Keychain
  2. Search Brave Safe Storage
  3. Double-click the entry found, click on Access Control tab
  4. Press the + button in the bottom-left corner, and find Brave Browser in your /Applications directory
  5. Upon seeing Brave Browser added to the list, click Save changes and enter your password
  6. Re-launch Brave

Then see if password/payment data is correctly saved in the browser.

I have a similar problem with autofill.

Description of the issue:
Whenever a webpage appears asking for my name and password Brave does not autofill. In preferences → additional settings → autofill → passwords → offer to save passwords and auto signin are both turned on. The saved passwords are listed.

Let’s say I go to A list of my gmail accounts appear. I select an account. Another page appears requesting my password. When I place my cursor in the password field I’m prompted with a list of gmail accounts and passwords. When using other browsers the password is automatically filled in. Why isn’t Brave doing the same?

When I go to my school signin page (the page displays unfilled username and password fields). When I place the cursor in the username field I’m prompted with a list of user names. Again other browsers automatically fill in the user name and password. Why isn’t Brave doing the same?

Additionally in Preferences → Privacy and Security → Clear Browsing Data - > On Exit → Passwords and other signin data (this option is unchecked).

Steps to Reproduce (add as many as necessary):

  1. I guess try going to

Actual Result (gifs and screenshots are welcome!):
Auto-Fill fields do not auto-fill

Expected result:
The fields should auto-fill

Reproduces how often:
always and for any web page requesting login info.

Brave Version(See the About Brave page in Settings ):
Version 1.22.71 Chromium: 89.0.4389.114 (Official Build) (x86_64)

desktop macos
Big Sur 11.2.3

Additional Information:

Thanks ahead of time for your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.