Autocomplete passing local addresses to search

Description of the issue:

Browser takes a local address such as ‘router.lan’ which resolvable as either ‘router.lan’ or ‘router’ via the local name resolving as .lan is
specified as a local domain. Autocomplete fails to resolve this locally and passes it to the search engine.

This makes it difficult to reach local resources such as routers or other machines. Only their numerical address works. I suspect even a fqdn wouldn’t work as it would resolve to a different value internally to externally.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

register a local domain on router
prove you can resolve it locally with ‘ping name.domain’
attempt to connect using the browser using any url

Actual Result (gifs and screenshots are welcome!):

Passes enetered name to duckduckgo

Expected result:

Connects to local resource

Reproduces how often:


Operating System and Brave Version(See the About Brave page in the main menu):

Linux (debian 11) Brave V1.35.103
Untested on other OS

Additional Information:

some further information about local domains indicating .lan is a reasonable choice.

I have on the local network routers, printers, other computers, test equipment etc. Many of these have a web page. I don’t mind entering at least a local domain (the name alone is sufficient for correctly-working software such as telnet or ssh) but there needs to be a way to prevent an unwanted search.

@artag ,

Possibly, Brave Browser does not find an IP address for the domain of interest to you, and passes the problem off to the default search engine.

You may need to test DNS resolution possiblities


You might need to Disable DNS over HTTPS?

Do you need HTTPS for connections to your network gear?

Might you edit your Linux OS hosts file?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.