Auto-contribute & rewards not working

Description of the issue:
I’ve been using Brave on Android for several months now so have accumulated almost 20 BAT by now. I’ve had auto-contribute enabled the whole time, but I don’t think it’s ever actually worked. Perhaps it’s bugged out, as evidenced by the “next contribution date: Aug 21” which has been there since I started using the app.

EDIT: Forgot to mention this, but I also can’t claim my rewards for this month. It says “your rewards from ads are here!” but when I tap “claim” it just spins the loading wheel forever lol. Just wanted to let you guys know since I would assume it’s a bug :wink:

How can this issue be reproduced?
I’m not sure if this is a reproducible bug. It might be based on mobile device specs or something outside the user’s control.

Brave Version( check About Brave):
1.5.1 from the Google Play store.

Mobile Device details
Samsung Galaxy S9+ with stock Android 9

Do you get any errors that contribution failed? Its probably going on a retry since it wasn’t able to contribute on Aug 21st. Re: ads grant what happens if you remove the app from memory and relaunch and try to claim it again?

No, I don’t get any actual error messages, I just haven’t seen my BAT decrease (I had originally set it to auto contribute as much as possible) and I never saw it in the Rewards Summary. However now it’s showing an updated payout date of Dec 5, and it actually auto contributed this month, so it must have corrected itself, haha. I’m still getting an infinitely spinning loading wheel when I try to claim my rewards though.

ADDITIONALLY: I’ve just started running into an error on some sites. Has only happened a few times so it might not be a persistent issue. Can’t tell for sure yet.

We have has some rewards outage which is under investigation.

same here… can’t claim my rewards either