Auto-complete searches NOT WORKING even when TOGGLED ON

Description of the issue:

Unable to turn on “Auto-complete searches and URLs” switch. Because of this searches don’t auto-complete when using Google.

How can this issue be reproduced?

  1. Enter Settings and then the Privacy category in Settings.
  2. Toggle the switch for “Auto-complete searches and URLs” to on
  3. Leave the Privacy category and go back to the main Setting menus
  4. Go Back into the Privacy category
  5. The switch is now off. And searches with Google are not auto-completed

Expected result:

The switch should remain on and searches with Google should be auto-completed

Brave Version( check About Brave ):

Brave 1.11.104

Computer Device details

Macbookair MacOS Mojave

Additional Information:

Your Brave is outdated. Try with the latest release.

Thanks

I just updated it and I still have the same issue.

I’m on my mac by the way

@santicet,
You’re posting in the mobile support category and w/your Android phone. Is the issue you’re describing happening on macOS or your Android device?

Ok I changed to desktop support. The issue is on my MacOS

@santicet,
So I can’t seem to reproduce this on my end. I am on OS Catalina though – may have to do with Mojave but that seems unlikely. Can I ask if this is the only setting that exhibits this behavior or are there other options that toggle themselves off in this way?

The auto-complete option is always toggled “ON” but never works. This only happens when I’m in one of my 4 brave account profiles.

@santicet,
I’m asking if any other option exhibits this same behavior or if it’s just this option. Also, if it’s profile specific, it’s probably some weird cache data causing the conflict, or a particular extension.

  1. Can you try clearing your cache/browsing data on the relevant profile and see if the issue persists?
  2. As an additional test, if the above doesn’t work, try disabling any extensions installed on the profile and see if you get different results.

No, there is no other option that exhibits the same behavior. I cleared my cache and browsing data, issue is still there. I also disabled all my extensions but the issue is still there