Auto-complete searches and URLs switch not working

Description of the issue:

Unable to turn on “Auto-complete searches and URLs” switch. Because of this searches don’t auto-complete when using Google.

How can this issue be reproduced?

  1. Enter Settings and then the Privacy category in Settings.
  2. Toggle the switch for “Auto-complete searches and URLs” to on
  3. Leave the Privacy category and go back to the main Setting menus
  4. Go Back into the Privacy category
  5. The switch is now off. And searches with Google are not auto-completed

Expected result:

The switch should remain on and searches with Google should be auto-completed

Brave Version( check About Brave):

Brave 1.5.2

Mobile Device details

Android 8.1.0, Moto G5

Additional Information:

I’m having this exact same problem with my Oneplus 7Pro running Android 10.

It was working fine some time ago but an update must have broken this.