Audio problems on MacBook and iPad

iPad) When starting a vlog post on uTube the audio is greatly diminished, correction for this is to refresh the browser then the volume is back to where it was set.

MacBook) When trying to listen with earphones out of USB port with an DAC (Dragonfly) there is no audio, the audio come out the MacBook speakers regardless of the sound preference settings.

Hi @rpd369 - thanks for reporting. What OS and Brave version are you using on your desktop? Just to confirm, it does work as expected in other browsers? With the Dragon fly, is it just YT that sound isn’t working on, or other sites as well?

Thanks in advance!!

Version 1.2.42 Chromium: 79.0.3945.117 (Official Build) (64-bit) on the MacBook

Version 1.14.2 (19.12.12.17) on the iPad

When using Safari on uTube there is not an issue, same with the iPad Safari. I went to Gaia, my subscription and the same audio problems exist as in uTube, selection of output to my earphones does not switch.

@rpd369,
Can you confirm that uTube = YouTube? Or are these two different websites?

Opps, sorry YouTube.

@rpd369,
Thank you for clarifying.
If you connect your headphones into your macbook directly (that is, not through the Dragonfly adapter), does sound play through the headphones properly or is this also mute?

The headphone port shuts off the speakers, as usual and the audio works. The sound preference selection menu shows headphones and the AudioQuest (Dragonfly) as selectable items and as noted in previous texts, even though the AudioQuest is selected no audio is forthcoming.

@rpd369,
I’d like you to take the AudioQuest adapter out of your computer entirely. Simply attach your headphones to the laptop and see if you get the same behavior. If not, the issue is likely between the AudioQuest and Brave.

Now using the headphone port, it turns off the internal speakers when plugged in. There is another problem I just discovered, I cannot route audio from Brave browser (using the sound preferences) to my Homepod speaker, it defaults back to either the headphone port or the internal laptop speakers. When selecting the HomePod, the speaker turns on but there is no output.

There was an upgrade this evening and I have installed it. But there are no changes to the problems we have discussed to this point.

@rpd369,
This is starting to sound more like a system issue rather than a Brave issue. If you’re using Chrome, do you get the same results or are you able to adjust the audio output device as intended?

As was mentioned before the Safari browser does not have the problem. I do not, nor will I install chrome for testing purposes. I was not having this problem before the more recent Brave updates.

Thanks

@rpd369,
Does this happen for any website you use in Brave or is it limited to Youtube? Also, can you click the “lock” icon in the address bar and check to see if you have the Audio permission set to Block by chance/accident?

Gaia.com steaming subscription website defaults to internal speaker/headphone port

KIssAnime.ru streaming website defaults to internal speaker/headphone port

https://www.macworld.com/ streaming from website defaults to internal speaker/headphone port

Brave address bar is set to “Automatic (default),” defaults to internal speaker/headphone port. Address bar set to “Allow,” defaults to internal speaker/headphone port.

Thanks

@rpd369,
Can you try creating a new browser profile (Menu --> Create profile), visiting one of the sites you mentioned above and note whether or not you get the same behavior?