Audio output not working in google hangouts/meet

Description of the issue:
When using google hangouts/google meet, I cannot hear anything, even when testing audio. However, visiting other websites on brave, my audio works fine. (Other people on the video call can hear me, so it seems to be just affecting output not input.)

Steps to Reproduce (add as many as necessary):

  1. Navigate to google hangout or google meet
  2. Confirm Settings > Speakers set to headphones / Built-in
  3. Put on headphones
  4. Test audio

Actual Result (gifs and screenshots are welcome!):
5. Hear nothing

Expected result:
5. Hear test sounds

Reproduces how often:
Every single time

Brave Version(about:brave):
Version 0.64.77 Chromium: 74.0.3729.169 (Official Build) (64-bit)

Reproducible on current live release (yes/no):
yes, just updated

Additional Information:
please notify me when fixed

1 Like

I’m seeing the same thing.

brave version: Version 0.65.118 Chromium: 75.0.3770.80 (Official Build) (64-bit)

mac osx 10.14.5

@meg4brave,
Thank you for reaching out to us!
I believe that this is due to Brave’s Shields blocking the site from reading information about your device (like what/how to send audio to your speakers, in this case). Try the following:

  1. Visit hangouts/meet website
  2. Click the lion icon in the address bar to reveal the Shields drop-down panel
  3. Change the Device Recognition setting to Allow all
  4. Let the page refresh

Try testing the audio again and let me know if the issue is resolved.

@meg4brave,
Actually, upon further testing it may not be Device Recognition – this may be a general “permissions” issue.
When you first land on the site – lets say Google Meet – You should have been are you prompted to allow the site to use your mic/camera? In addition, when you click “test” with the appropriate speakers selected, you should have been prompted to allow Autoplay for the site – were you and if so, did you do so?

To confirm, if you click the “lock” icon on the Google Meet site, it should look something like this with the following permissions displayed:

Hey @jvaleski,

What’s up! Been a little while :slight_smile: Hope things are well. Did you see the autoplay prompt (little play button show up on the right side of the url bar). If you allow the site and reload does it work?

We’ll need to clean this up but wanted to verify if that works for you. I was able to get it working with that setting added.

Also, per @Mattches comments above, selecting lock icon should have the camera/microphone settings to allow.

1 Like

@rebron2000! :). autoplay was off… I’ve flipped it to on and will test this week when I’m back in the office; thanks!

autoplay turned to “on” works. thanks!

2 Likes