"ArtStation Learning" doesn't work again?

A similar topic has been created in the past, the solutions no longer work: Artstation "something went wrong during native playback"

I have tried the following solutions in Brave Release to no success:

  • Disabled Brave Shields
  • Disabled all extensions
  • Opened via private mode
  • Widevine enabled (as well as disabled and re-enabled again)
  • Playback works in a different browser (Chrome)

@c4blec,
Thank you for reaching out.
On my end, I’m able to view video content on the site without issue. This is with default Shields enabled. Can you right-click on the page, then select Inspect and send a screenshot of any output in the Console tab?

Hi,

I checked https://www.artstation.com/learning/courses/2Yo/30-years-of-film-design-with-doug-chiang/chapters/Q5xQ/part-1 which indeed shows an error. But same error shows in Chrome. Is it broken in Chrome @c4blec ?

Its checking geo location, Going from NZ (blocked for some reason) to US fixes it

What I see:

Works in Chrome:

What error message is showing under Brave?

Okay, thats widevine issue. Try disabling widevine, restart. re-enable widevine and re-test.

Tried testing with Widevine both disabled and re-enabled.
Still get either “Aborted” or “Something went wrong during native playback”.

Try in Brave Beta, as a test. I rejected widevine and get the Something went wrong during native playback
Then refreshing the page, and accepting widevine playback worked. Testing was done on this link: https://www.artstation.com/learning/courses/2Yo/30-years-of-film-design-with-doug-chiang/chapters/Q5xQ/part-1

Works in Brave Beta, then after configuring Brave Beta similar to my current Brave Release install, I found that the problem was caused by “Protected content” being “Blocked” found in: brave://settings/content/protectedContent

Thanks for the helping me troubleshoot, fanboynz.

2 Likes