Articles from medium.com are missing embedded content


#1

This has been a problem for me for a very long time, some embedded content from Medium articles is missing, especially often when reading programming related posts. It does not help to disable Brave shields, nor does it help to disable privacy settings in the Android app. Android version does not matter, I’ve seen this since Marshmallow and I’m currently on Android O.

Randomly chosen article to demonstrate the issue: ‘The Art of Computer Programming’ by Donald Knuth

Screenshot demonstrating the issue:

The articles work fine in other browsers.


Fingerprint protection toggle is broken when enabled in Settings
#2

hi. cc @serg on this


#3

That’s odd… I tried both on my PC and my Android device, and couldn’t get that same result. I had shields up with the default settings on both devices, and the images load fine…


#4

thanks for the report!


#5

#6

#7

Thanks. I have the same problem, but when browsing from the Brave desktop browser, not mobile. It’s difficult enough to sign into Medium, especially when trying to view a blog that’s published under their own domain name but using Medium.com as their back-end (for aggregation, social features, and so on).

Even when I’ve successfully signed into Medium (surprisingly difficult to do), viewing the blog results in missing content, like the original poster mentioned. I think some content is being classified as being from a third party and thus needing to be blocked.

I forgot what site this was on. I was in a hurry, so just loaded the page again in Chrome :sweat_smile:

Josh


#8

Has there been any update to this thread? The same thing is happening to me… I’ve attached a GIF which includes the content URL Medium attempts to ping!

Mediumcontenterror|645x500

System specs:

Brave: 0.19.131
rev: da2f34787e51eb44190a7a77249e100fb2368306
Muon: 4.5.36
libchromiumcontent: 63.0.3239.132
V8: 6.3.292.49
Node.js: 7.9.0
Update Channel: Release
OS Platform: Microsoft Windows
OS Release: 10.0.16299
OS Architecture: x64


#9

Hi @eighteendumb

I’m unable to view your gif, but have you tried adjusting your shield settings (for cookies, fingerprinting protection, etc) and seeing if that helps?

Lauren


#10

Hi @LaurenWags,

Thanks for the follow-up. I just tried the same site again since your post, and it seems to have been resolved. It’s odd, since I tried with Chrome and it had worked, but maybe it was due to a Brave update.

Thank you again for your follow-up!


#11

Thanks for reporting back @eighteendumb - if you notice it again please let me know.

Lauren