Are site-specific Shields 'settings' that remain as a default supported?


#1

Shield settings for GMail (i.e., Call Phones from GMail) don’t seem to persist through a system restart.

Is there a way to make ‘Shields off’ & other settings that affect that service (e.g., Allow Autoplay) a default for specific webpages/websites?

Thanks.

@Mattches Recommended tag for community posts: “Shields”


#2

Shields already works this way.
If you go to gmail ( or any site) and turn Shields off or edit one of the settings for a specific site, Brave will remember this and keep these settings for the site until you change them.


#3

Thanks but that didn’t happen. You may recall that I set up Shields in the way you describe recently with your assistance.

I didn’t make any changes after that. The only thing I did do that might have had an effect on those settings is that I restarted my Mac in between the successful use of Call Phones from GMail and its not working again.

When at some point after that restart I tried to use Call Phones from GMail I ran into the same issues we had discussed. That Shields had been re-enabled was clear. It was orange instead of gray.

Even after disabling Shields, neither the phone ring nor the other party answered could be heard, until Allow Autoplay was again enabled as well.


#4

Lets have a demonstration and/or learning moment. Try the following:

  1. Launch Brave (I assume you’re using the dev build still) and visit ign.com (I use this site frequently because it has a ton of elements on it which makes it easy to test lots of different issues on).
  2. Open you Shields panel, and choose to block scripts - the images on the site should appear fuzzy and many may become unresponsive.
  3. Now, close the ign.com tab as is
  4. Visit some other sites (or not, doesn’t matter really) and then close and quit your browser
  5. (Optional Step) Turn off your machine
  6. (Optional Step) Take a walk and get some fresh air
  7. (Optional Step) Make yourself a nice meal
  8. Return to your machine, turn it on, launch Brave and return to ign.com

The Shields settings should still be exactly the same as when you left them - no matter what you do. With the exception of changing Shields settings somewhere, or resetting/reinstalling/uninstalling Brave, these settings will not change once you’ve set them.


#5

With the exception of changing Shields settings somewhere, or resetting/reinstalling/uninstalling Brave, these settings will not change once you’ve set them.

@Mattches I’m just reporting what happened. I don’t doubt what’s supposed to happen.

If I would proactively have to have changed the Shields settings to have run into the issue again (given that it had been fixed prior to that), then I can assure you I didn’t do that, nor would I have forgotten it if I had. I also had no reason to change those settings. They were working fine the way they were.

Since this isn’t the only issue I’ve been having, I think I’ll switch back to Core & see whether I fare any better with that version.

I’m not a programmer but I’m not sure that the possibility that Google does something on its end should be discounted. Maybe it loses snoopability when a restart clears data it wants to see & tries to regain it by forcing ‘shield’-like behavior to be turned off as a default.


#6

@mk7z,
As often requested, if you could capture a recording of this behavior that would be great. Because if this is truly happening that there may be a significant bug in our code.

If you’re willing, take a short recording of the behavior and reply with it here so I can take a look. Screen recording resources found here:


#7

Just want to make sure. @mk7z, did you “Clear browser data” before quit Brave?


#8

@mk7z, did you “Clear browser data” before quit Brave?

Yes, cache & cookies,… would that have done it?

– i.e., do Shields settings work from cookies?


#9

I would have done that if I’d been able to predict it.

Keep in mind that I went into my Google account to make a call. I wasn’t expecting any problem.

When the call had the reported issues, I looked at the Shields icon & saw that it was orange.

I flipped it to gray.

I tried to phone again. Same issue. I remembered having to also change the Autoplay setting, so I did that.

I tried to call again. It worked.

I don’t see what I could have recorded (or can record now) since what happened occurred without any expectation that it would occur, and at this point it’s already happened.


#10

This should not effect your Shields settings. You should find that any time your Shields are set for a site they will remain set until changed (or browser settings are reset). If you can find reliable steps to reproduce the issue I’d be happy to troubleshoot it and/or log an issue if necessary.


#11

Okay. That system restart I did was related to another issue I posted about. I had actually just wanted to ‘clear browser data’ but couldn’t get it to work. It just kept going on indefinitely & when I finally canceled there was no change in the number of items.

It seemed to work normally after the restart, instantaneous in fact.

Next time I do a restart I’ll record what I can. Obviously that won’t include the restart, but I’ll note the Shield status for GMail before & after. I’ll make sure it’s turned off before I restart. So it’s just a matter of whether after the restart GMail loads with a gray shield or an orange one.

Now that I think of it, there’s not much to record there, is there? :wink:


#12

I can report that this just happened again. It must be the case that a computer restart (or a Brave update, if those are automatic & one just occurred) is causing a Shields Off status to go back to Shields On.

I didn’t realize it until I tried to make a call (Call Phones from GMail) and saw not only the familiar prompt to enable the mic, but also watched my call get answered without my having heard the phone ring or hearing the answering party. I didn’t at any time change the Shields Off status that I’ve had since this was last discussed here a little over a week ago.

I didn’t just do the restart. That was last night. But it’s the first time I’ve used Call Phones from GMail since that restart. So again, the only other thing I can think of that might be causing this toggling of the Shields setting is a Brave update if those occur in the background.

image


#13

@mk7z Based on your screenshot, it seems that you’re using Private Window or Private Window with Tor. Am I right? :thinking:


#14

Was going to say the same thing - could be just a regular private window as well but either way this would be the answer.
@mk7z,
If you’re browsing in a Private window, Shields settings (along with any other data such as sites visited/history, logins information, etc) will not be saved. They will always revert to the Shields defaults settings reflected in your settings (Settings --> Brave Shields Defaults) after you close/end that session.

If this is the case, it would explain the issue you’re encountering.


#15

Yes, not a TOR window, just Private. Thanks.


#16

OK, thanks, I didn’t realize ‘Shields’ settings were subject to that.

But by “close/end that session” are you referring to ‘quitting’ Brave?

I don’t usually do that. I only do it when I’m rebooting because otherwise an error message will ask me to & won’t complete the restart until I exit the browser.

So my sessions normally close/end just by closing the case of my MacBook, not by quitting Brave.

In practice, that means that quitting Brave is synonymous with rebooting. But I see what you mean. When the browser restarts it’s pulling up the default (Shields On).

And I assume that if I quit & restarted in a normal window the Shields Off status would be preserved instead (?)


#17

Almost - In this case we’re specifically referring to quitting/closing a Private session. To clarify, any time you browse using a private window, this is your private “session”. Closing this window would be ending your session. Every time a fresh private window instance is open, default Shields settings are loaded.

Correct!