Apt-release error

I have installed the brave browser on an acer notebook (AMD Ryzen 5 2500U). The os is linux mint. If i do “apt update” i get the following msg:
N : Skipping acquire of configured file ‘main/binary-i386/Packages’ as
repository ‘https://brave-browser-apt-release.s3.brave.com stable
InRelease’ doesn’t support architecture ‘i386’.
How can i fix this?

Bumping this. The often-repeated recommended action doesn’t ever work for me as a way to ensure that my prefered brower is up to date. This shouldn’t be hard to address with some cooperation between Ubuntu and the Brave-browser folks.

There is nothing unusual in my hardware. From System Info:

Software
    Operating System: Kubuntu 23.10
    KDE Plasma Version: 5.27.8
    KDE Frameworks Version: 5.110.0
    Qt Version: 5.15.10
    Kernel Version: 6.5.0-28-generic (64-bit)
    Graphics Platform: X11 

Hardware
    Processors: 8 × Intel® Core™ i7-8650U CPU @ 1.90GHz
    Memory: 15.5 GiB of RAM
    Graphics Processor: Mesa Intel® UHD Graphics 620
    Manufacturer: Dell Inc.
    Product Name: Latitude 5490
    

Below are the repeatable results from following the Brave Browser installation instructions for Ubuntu.

~$ sudo apt install curl

    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    curl is already the newest version (8.2.1-1ubuntu3.3).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

~$ sudo curl -fsSLo /usr/share/keyrings/brave-browser-archive-keyring.gpg https://brave-browser-apt-release.s3.brave.com/brave-browser-archive-keyring.gpg

    (no command line output)

~$ echo “deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg] https://brave-browser-apt-release.s3.brave.com/ stable main”|sudo tee /etc/apt/sources.list.d/brave-browser-release.list

    deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg] https://brave-browser-apt-release.s3.brave.com/ stable main

~$ sudo apt update

    Hit:1 http://ca.archive.ubuntu.com/ubuntu mantic InRelease
    Hit:2 http://ca.archive.ubuntu.com/ubuntu mantic-updates InRelease                                                                              
    Get:3 http://apt.insync.io/ubuntu mantic InRelease [5,536 B]                                                                                    
    Hit:4 http://ca.archive.ubuntu.com/ubuntu mantic-backports InRelease                                  
    Get:5 https://brave-browser-apt-release.s3.brave.com stable InRelease [7,547 B]
    Hit:6 http://security.ubuntu.com/ubuntu mantic-security InRelease
    Get:7 https://brave-browser-apt-release.s3.brave.com stable/main amd64 Packages [12.7 kB]
    Fetched 25.8 kB in 1s (23.3 kB/s)   
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    1 package can be upgraded. Run 'apt list --upgradable' to see it.
    N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'https://brave-browser-apt-release.s3.brave.com stable InRelease' doesn't support architecture 'i386'

~$ sudo apt list --upgradable

Listing... Done
 brave-browser/stable 1.65.132 amd64 [upgradable from: 1.63.174]
 N: There are 54 additional versions. Please use the '-a' switch to see them.

At this point, I switched over to Synaptic Package Manager, and quick filtered for “Brave”. I selected brave-browser from the Package list, then clicked on menu item ‘Package’ and selected ‘Force Version’. A dialog appeared with
“Select the version of brave-browser that should be forced for installation. The package manager always selects the most applicable version available. If you force a different version from the default one, errors in the dependency handling can occur.”

Scary! Anyway, from the ‘Force version’ drop-down list, I selected the most current one 1.65.132 (stable) from the 55 choices listed. Then I applied the marked changes.

I now have the most current version installed, but it remains a manual-overide situation.

~$ sudo apt update

    Hit:1 http://security.ubuntu.com/ubuntu mantic-security InRelease
    Hit:2 http://ca.archive.ubuntu.com/ubuntu mantic InRelease                                                 
    Hit:3 https://brave-browser-apt-release.s3.brave.com stable InRelease                                      
    Hit:4 http://ca.archive.ubuntu.com/ubuntu mantic-updates InRelease
    Hit:5 http://ca.archive.ubuntu.com/ubuntu mantic-backports InRelease
    Get:6 http://apt.insync.io/ubuntu mantic InRelease [5,536 B]
    Fetched 5,536 B in 1s (6,097 B/s)
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    All packages are up to date.
    N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'https://brave-browser-apt-release.s3.brave.com stable InRelease' doesn't support architecture 'i386'

WHEN are you going to fix this, Brave ?? …This has been a “feature” of brave for YEARS.
I bring another pc into my collection and install my favourite browser…Brave…and I am still presented with this crap which reeks of inability on your developers part to do their job.
my favourite browser is about to change…and when I change to another, that change will be permanent.
You choose to ignore this, thinking you have sufficient followers to get you through?..think again. you will ignore feedback of this nature at your peril .

You are aware of my email address…contact me if you so desire.
[email protected]