Apps/Shortcuts Do Not Open [macOS]

Hello everyone,

I am facing a problem with some apps/shortcuts not opening on macOS. Thanks for your suggestions.

Description of the issue:
After I create a shortcut of a website and try to open it (in /Users/user/Applications/Brave Browser Apps), it won’t open. The app’s name flashes in the macOS’s Menu Bar and disappears. It is obviously trying to open itself but then it crashes.

Examples: https://web.whatsapp.com/, https://community.brave.com/ didn’t work at all, but https://github.com/ worked (but did not open in a separate new window even the option had been checked when creating the shortcut).

How can this issue be reproduced?

  1. Open a website, go to Menu > More Tools > Create a Shortcut.
  2. Give the shortcut a name, check “Open in a window”, click Create.
  3. Folder “Brave Browser Apps” opens, your new Web.app is in it. Double-click on it, it won’t open.

Video: https://imgur.com/a/8g7CHr5
(Behance had “Open in a window” checked, The Newyorker did not)

Expected result:
Double-clicking the newly created shortcut should open the website.

Brave Version( check About Brave):
Version 1.15.75 Chromium: 86.0.4240.99 (Official) (x86_64)

Additional Information:
The same issue appears even with the “Install Brave Community App” from the browser’s main menu. The “Brave Community.app” shortcut won’t open this website.

//Updated, it seems like the “Open in a window” checkbox matters.

Hello @xnajja

i tried it and it work fine

so could you disable all extension then try again if it work then enable them back one by one till you get the one that cause the issue

if not then could you try to create new profile then close the other window then try again and see if it work

hope that help and have a nice day

Hello @justsomeone1,

Thanks for your reply. Disabled all extensions, reinstalled Brave completely, tried a new profile, none of this helpded.

Actually, it seems like it does depend on whether the “Open in a new window” is checked or not when the shortcut is created.

If not checked: For some websites it worked (they opened in the browser’s main window), but WhatsApp still didn’t open at all.
If checked: No shortcut worked, neither in a main window or new separate window.

I’ve used the same feature for months in Chrome, so I think I know what it is expected to do. In Brave, it behaves weirdly.

//Update: I’ve added a link to a video to my first post.

Thanks

you welcome @xnajja

if you comfortable with command line could you close brave and make sure that it does not have any running process
then use the following argument in the command line to start brave with it

i know you tried to create new profile but sometime crazy stuff happen lool

uninstall and reinstall does not remove everything there still profile data there unless if you removed it

by the way do not remove it

hope it help and have a nice day

1 Like

ok will check the video

before trying the command stuff try
to disable this Continue running background apps when Brave is closed

from here brave://settings/system

Hello,

in my settings, there is no Continue running background apps when Brave is closed option. All I see is hardware acceleration, proxy settings, and reset.

When I tried the terminal command:
XXXXX$ /Applications/Brave\ Browser.app/Contents/MacOS/Brave\ Browser --user-data-dir-name=blahblah

It started the browser to my current profile, it did not create a new one. Or is the command incorrect? I’ve tried deleting the fully set up profile and creating a new one again, no plugins, settings changed, etc. Created a shortcut for WhatsApp, and it did not still work.

Thanks

Hello try first to create the folder then check this link for the command

there was misstype on the command i send earlier sorry for that

hope it help and have a nice day

1 Like

Hello @justsomeone1,

I followed this procedure in Terminal. It successfully created a new empty profile, and the shortcuts worked!

So, I closed the empty profile, switched to my main one, and tried it out. And it works! Cool!

Thanks a lot for your help, man! I really appreciate it! :clap:
Have a great day.

2 Likes

you very welcome @xnajja

and glad it worked

thanks a lot and you too

1 Like