Apparently something has happened since I installed Brave for the last time

linux

#1

Today I did for clean install of Pop_OS! on my laptop. I had Pop_OS! 18.10 running before as I do now. But alas! Tried to install Brave without success…

Here is what happened:

pdp-7@pop-os:~$ curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key add -
OK
pdp-7@pop-os:~$ echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ `lsb_release -sc` main" | sudo tee /etc/apt/sources.list.d/brave-browser-release-`lsb_release -sc`.list
deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ cosmic main
pdp-7@pop-os:~$ sudo apt update
Hit:1 http://ppa.launchpad.net/system76/pop/ubuntu cosmic InRelease
Hit:2 http://us.archive.ubuntu.com/ubuntu cosmic InRelease               
Get:3 http://us.archive.ubuntu.com/ubuntu cosmic-updates InRelease [83.2 kB]   
Err:4 https://brave-browser-apt-release.s3.brave.com cosmic InRelease          
  403  Forbidden [IP: 151.101.86.217 443]
Get:5 http://us.archive.ubuntu.com/ubuntu cosmic-security InRelease [83.2 kB]
Hit:6 http://apt.pop-os.org/proprietary cosmic InRelease 
Get:7 http://us.archive.ubuntu.com/ubuntu cosmic-backports InRelease [74.6 kB]
Reading package lists... Done                                  
E: Failed to fetch https://brave-browser-apt-release.s3.brave.com/dists/cosmic/InRelease  403  Forbidden [IP: 151.101.86.217 443]
E: The repository 'https://brave-browser-apt-release.s3.brave.com cosmic InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
pdp-7@pop-os:~$ 

I don’t know what have happened since I successfully installed Brave browser last time, but someone broke something it seems.

Tried beta also, with same result.

How do do this? Would like to get back my Brave…


#2

Were you using the installation instructions found here?


#3

Well I c+p from here:
https://brave-browser.readthedocs.io/en/latest/installing-brave.html#linux

But seems to be exactly same lines, which you can see from my terminal snip if you look very very closely.

And as I said, it has worked before. But not this time.


#4

Give me a bit to dig into this - I’ll be back with more info.


#5

Thanks!

Don’t really know what has happened, but as I did some searches here on forums I found out that there has been ubuntu repository tweak of some kind… probably something to do with this… dunno.


#6

Talked to our build teams - had them open an issue to include “cosmic” in aptly script upload. You can view/track it here:

https://github.com/brave/devops/issues/464

Sorry for any inconvenience this may have caused you.


#7

Thanks for this!

I’ll check for the updates on the matter.

EDIT: Except that link doesn’t work. Getting 404…

Only inconvenience is that I have to use Firefox until I can install Brave.

Let’s see if links will open from external sources after this new install… which is weird since I have another laptop that is also running Pop_OS! 18.10 and there links are opening as they should.

Thanks again!


#8

My pleasure.
Ah, my bad. It’s logged in a private repo. That’s on me.
However, it is logged and will be addressed. We appreciate you bringing this to our attention.


#9

No problem!

Things happen when you do things :smiley: