Any way to temporarily disable Brave Browser Helper (Renderer)?

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting


I am learning Spanish on DuoLingo. If I complete two consecutive lessons perfectly, I am offered the opportunity to level up. Clicking the “Accept” button performs this. When I was using Safari, it was not uncommon at this point for the browser to spin out indefinitely. So I switched to Brave (currently running v. 1.25.72) and the problem went away – until yesterday. I activated the Activity Monitor and found that there was a process called “Brave Browser Helper (Renderer)” that was eating up an obscene amount of CPU, causing other things to grind to a halt.

Is there a way to disable this helper (at least temporarily while I do my DuoLingo)? And would this be likely to interfere with Duo?

@Phantor48,
Thank you for reaching out to us.

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.