Any update on a fix for the black screen/layer refresh problem?

Has there been any progress in getting rid of Brave’s breaking of Google Maps and other sites with the black/dark screen bug?

I note that the old thread has been automatically closed but no sign the issue was actually solved…

From what I’ve seen it seems to be caused by a layer problem. Where Brave tries to refresh ALL layers instantly on the page.

I’ve so far seen this happen on Facebook messenger, Facebook newsfeed, Google Maps, Google Earth, and a few other websites. There seems to be something in Brave which makes it want to instantly refresh ALL layers, which ends up breaking some graphic layers. I have also seen Brave do this while the website is just sitting open with no interaction going on, it just flashes the screen dark for a fraction of a second, this is not something that has happened with Chrome, Firefox or Edge when I’ve been using these same sites with those browsers.

I’ve done diagnostics in Brave as follows;

  • Tried all shields off, Tried all shields on.
  • Tried all domains marked safe in NoScript.
  • Tried 2D Layers Only on sites that support it.
  • Tried a comparison between four different browsers (Brave is the only one with this bug).
  • Tried disabling all extensions.
  • Checked Radeon Driver up to date (not radeon issue).
  • Checked all third-party background tasks during bug.

No resolution. Bug remains (Only in Brave browser, Firefox, Chrome and Edge don’t produce the same bug).

The bug seems to come at random, whether the site is being interacted with or not, it can be sitting there with no mouse movement and still happen, or it can happen when scrolling, or when hovering over a popup layer, totally at random.

Most often instance of the bug appears when grabbing and scrolling in google maps, sending the map black and unreadable but leaving the frame and top layers in place.

This definitely seems to be a layers bug where Brave is forcing a layer to update when it shouldn’t be.

Current version: Brave 1.32.113 Chromium 96.0.4664.45 Official Build 64-bit.
Windows 7 Ultimate Edition 64bit.
Extensions installed: Social Fixer for Facebook, NoScript, uBlock Origin.

It seems no one wants to touch on the subject, even though this bug has been affecting people since around 2018 (that was the date of the original thread this bug appeared in, and which was closed without solution).

It’s a nice browser in other respects but if it’s constantly going to break most of the major websites people use on a daily basis it becomes redundant pretty quickly and people have no choice but to start using other browsers.

Google Maps and Google Earth were smooth as proverbial silk under Chrome on this exact same setup, under Brave it chunks and shudders like it’s being run on a 486 (this system is an i7 btw), and no amount of trial and error on the settings seems to improve that…

Other things which just don’t feel right:

  • Constant very high cpu and memory load of brave.exe in task manager, even on basic websites with only one tab open.
  • 11+ instances (sometimes 20+) of brave.exe in task manager even when only one web page is open with only three extensions installed.
  • And of course the ‘unsolvable’ random refreshing of layers brave does which breaks many web sites like google maps.
  • Saved usernames and passwords on websites don’t auto-fill fields in Brave, only the username appears in the field, both got filled in Chrome, Firefox and Edge.
  • Brave taking ages to bring up very basic text web pages, even with shields down for that page, where Chrome took at most a tenth of a second (this was a basic page just showing weather forecast for my area).

I had high hopes this would be the browser for me, I value my security, but this browser is doing some darn crazy and strange things and as I’ve seen in the community here when they’re reported very few times any real solution is come up with, leaving the bugs and problems to linger for years until users give up on it…

I won’t be going back to Chrome, so I guess it’s FireFox and NoScript now seeing as I can’t get any help or solution with this problem in Brave that’s been going around for many years without any hint of a solution or fix.

Ohwell :confused:
If there’s a fix released at some future point I might try Brave again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.